Bringing up modal dialog causes the selection to disappear

VERIFIED FIXED in M16

Status

()

Core
Selection
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Simon Fraser, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
Try this: in composer, hit return a bunch of times, then type a few lines of text 
(so that the text is near the bottom of the window, and won't be covered by any 
dialogs). Select some of that text.

Now bring up a modal dialog, e.g. by clicking Find on the toolbar. Note that the 
selection is hidden.

Here's what's odd here:
1. This only happens on windows (98 and NT)
2. This only seems to happen in composer; in browser, you can have a selection,
   bring up the 'Find' dialog, and the selection remains visible.
3. If you simply have two composer windows up, each with some selected text,
   and flip between them, the selection remains visible in the background
   window.

danm hypothesised that this might be an event handling issue with modal dialogs.
mjudge, what event are you responding to when you hide the selection?
(Reporter)

Comment 1

19 years ago
*** Bug 23681 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
OS: Mac System 8.5 → Windows NT

Comment 2

19 years ago
Happens on Linux, too.  Changing OS.
OS: Windows NT → All

Comment 3

19 years ago
setting to m16
Target Milestone: M16
(Reporter)

Comment 4

19 years ago
*** Bug 26396 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Added Simon Fraser to the cc list and also want PDT to consider this bug.
Keywords: beta1
(Reporter)

Comment 6

18 years ago
Since this affects Find and other functionality, I think we should move this to 
M15, P2, and consider for beta1. Mike, can you debug, and find out why the 
selecition is disappearing only on Win 95/98?

Danm/saair -- is this a focus thing?

Updated

18 years ago
Whiteboard: [PDT-]

Comment 7

18 years ago
change summary
note: this affects the spellchecker dialog as well as the find dialog
Summary: Bringing up a modal dialog in composer causes the selection to disappear → Bringing up modal dialog causes the selection to disappear

Comment 8

18 years ago
The dialog is frontmost, it has focus. If the selection listener disables 
selection based on a blur, which it looks like it does, it will get a blur when 
the dialog comes up because the dialog now has focus.

So, yes, this is a focus thing, but it is working correctly. 
(Reporter)

Comment 9

18 years ago
That doesn't explain why the behaviour differs between platforms, tho.
(Reporter)

Comment 10

18 years ago
OK, I just tried this again on Mac, and Mac appears to hide the selection on blur 
as it should. So I guess various focus bugs have got fixed that make this work 
everywhere now.

Comment 11

18 years ago
I should have read the bug more carefully, Based on
"If you simply have two composer windows up, each with some selected text,
   and flip between them, the selection remains visible in the background
   window."
... selection does not listen to focus. However, if I switch between a navigator
window and a composer window, the navigator window keeps the selection drawn,
but composer does not.

I'm 99% sure this isn't a focus bug, but rather something specific to composer. 
And I tried this on MacOS and WinNT with the same results, so this is not 
platform specific.
Hardware: PC → All

Comment 12

18 years ago
hey this looks fixed in today's 2/23 build....did someone forget to mark
it RESOLVED-FIXED....Mike?
(Reporter)

Comment 13

18 years ago
Mike hacked the editor specifically to not hide the selection on a blur event. 
When mail compose gets a Find dialog, we might need to tweak this there too.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
verified in 2/23 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.