If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Send unsent messages failed after restarting Thunderbird

RESOLVED DUPLICATE of bug 251371

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 251371
13 years ago
13 years ago

People

(Reporter: Ruslan, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Illegal input characters: Control chars on SMTP input for sending unsent
messages after restart if recipient name in russian (first and last, for
example, "Иванов Петр" (Ivanov Petr). Immediately send (without restarting
Thunderbird) successful.

Reproducible: Always
Steps to Reproduce:
1. Compose new message for recipient with russian name (first and last, for
example, "&#1048;&#1074;&#1072;&#1085;&#1086;&#1074; &#1055;&#1077;&#1090;&#1088; <peter@list.ru>")
2. Choose "File/Send Later"
3. Restart Thunderbird
4. Choose "File/Send Unsent Messages"

Actual Results:  
Warning messages:
For smtp.yandex.ru - "An error occured while sending mail. The server responded:
5.5.2 Illegal input characters: Control chars on SMTP input. Please verify your
email address is correct in your Mail preferences and try again."

For smtp.list.ru - "An error occured while sending mail. The server responded
<"<demiurch/"@yandex.ru>">: recipient address must contain a domain. Please 
verify your email address is correct in your Mail preferences and try again."

Expected Results:  
Successful mail delivery

"Tool/Options/Composition/...use 'quoted-printable' MIME encoding..." is "ON".
Message encoding is "Cyrillic (Windows-1251)"
(Reporter)

Comment 1

13 years ago
Created attachment 152904 [details]
SMTP logfile

"To" field contains "/" character
(Reporter)

Comment 2

13 years ago
Bug reprodused on Thunderbird nightly build 0.8 (20040711)

Comment 3

13 years ago
*** Bug 251371 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
> Compose new message for recipient with russian name (first and last, for
> example, "&#1048;&#1074;&#1072;&#1085;&#1086;&#1074;
> &#1055;&#1077;&#1090;&#1088; <peter@list.ru>")

Is that the To: field?
When I'd write a message to this recipient, I'd enter the cyrillic letters in
the UI. The message header of the message then looks as follows:
To: =?windows-1251?Q?=C8=E2=E0=ED=EE=E2_=CF=E5=F2=F0?= <peter@list.ru>
And it only uses
RCPT TO:<peter@list.ru>
when communicating with the server (send now and send later).

What does yours look like (source view of unsent message)?
From the log it looks like you put the whole address (display name + angle-addr)
in double quotes. But in this case it I get the error even when sending
immediately doesn't work too.
(Reporter)

Comment 5

13 years ago
> Is that the To: field?
> When I'd write a message to this recipient, I'd enter the cyrillic letters in
> the UI. 

I create a new address book card for name "Bobovsky Ruslan" (russian characters,
first and last names), address is 300881@list.ru. Then I compose a new message
(doubleclick this address book card on sidebar in new message window), and
choose "Send Later". Without restarting message sends OK. After restarting
Thunderbird - delivery fail.

> The message header of the message then looks as follows:
> To: =?windows-1251?Q?=C8=E2=E0=ED=EE=E2_=CF=E5=F2=F0?= <peter@list.ru>
> And it only uses
> RCPT TO:<peter@list.ru>
> What does yours look like (source view of unsent message)?

To: =?windows-1251?Q?=C1=EE=E1=EE=E2=F1=EA=E8=E9_=D0=F3=F1=EB=E0=ED?=
 <300881@list.ru>

> From the log it looks like you put the whole address (display name + angle-addr)
> in double quotes. But in this case it I get the error even when sending
> immediately doesn't work too.
i.e. To: "Bobovsky Ruslan 300881@list.ru" or To: "Bobovsky Ruslan
<300881@list.ru>"? No. It looks like: To: Bobovsky Ruslan <300881@list.ru>
(without quotes).

Comment 6

13 years ago
(In reply to comment #5)

> > The message header of the message then looks as follows:
> > To: =?windows-1251?Q?=C8=E2=E0=ED=EE=E2_=CF=E5=F2=F0?= <peter@list.ru>
> > And it only uses
> > RCPT TO:<peter@list.ru>
> > What does yours look like (source view of unsent message)?
> 
> To: =?windows-1251?Q?=C1=EE=E1=EE=E2=F1=EA=E8=E9_=D0=F3=F1=EB=E0=ED?=
>  <300881@list.ru>

Hm, no. I followed you description and resulted in a mail with exactly this To:
field. After restarting TB issued RCPT TO:<300881@list.ru> to the server -
everything fine.
Sorry I can't help. I tested with Mozilla 20040718 and TB 20040621 on Linux and
Mozilla 1.8a2 on Win95.
(Reporter)

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 251371 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.