document.open(..., "replace") doesn't work

RESOLVED DUPLICATE of bug 164821

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 164821
14 years ago
14 years ago

People

(Reporter: Warren Harris, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Supplying the "replace" argument to document.open is supposed to replace the
current page with any new html supplied by document.write. This doesn't work in
Firefox or Mozilla 1.7. Instead, the document.write html always stacks a new
page in the history.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Fixed back in April on trunk.

*** This bug has been marked as a duplicate of 164821 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.