Keyboard shortcuts on bookmarks menu starting with B or M cause folders starting with B or M to be ignored

RESOLVED DUPLICATE of bug 147267

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 147267
15 years ago
13 years ago

People

(Reporter: eaula, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

You can't use keyboard shortcuts (first letter of the bookmark) to cycle through
bookmarks starting with either B or M, instead they try to bookmark current page
or go to bookmark manager. 

B should cycle add-bookmark AND bookmarks starting with b, and m likewise with
manage-bookmarks and regular bookmarks.

Reproducible: Always
Steps to Reproduce:
1. Alt-B (keyboard shortcut to bookmarks)
2. B     (Trying to go to bookmark starting with B)
3. M     (Alternatively trying a bookmark starting with M)

Actual Results:  
Browser goes straight to manage bookmarks or tries to bookmark the page.

Expected Results:  
Cycle through bookmarks and manage-bookmarks or bookmark-this-page, depending on
whether you used b or m. Correct choise can then be taken with [enter].

Comment 1

15 years ago
More Information:
This problem exists on any menu that has non-static contents* (not just
bookmarks), and is due to the keyboard accelerator incorrectly (IMO) taking
precedence over the first-letter navigational idiom.

This should probably be reassigned to the owner of Menus or Keyboard Navigation,
since its scope is wider than just the bookmarks menu.

I've verified this behavior on 0.8, 0.9.1, 0.9.2, 0.9.3, and the latest nightly
build (11-Aug-2004).

* My presumption is that it's true of all menus, but that's difficult for me to
verify, and static menu items should already have an accelerator associated with
them anyway.

Expected Results:
1. If a menu item has an accelerator key defined, its first letter should be
ignored for purposes of keypress.
2. If a menu item does not have an accelerator key defined, its first letter
should act as an implicit accelerator key.
3. When a given menu contains multiple items with the same accelerator key
(whether explicit or implicitly set), pressing that key should cycle through
those items.

Comment 2

15 years ago
Another aspect of this "Menu or Keyboard Navigation" bug is as follows: when a
page  has its own accelerator keys, these take precedence over the top level
menu items. So for example when viewing this bug report and you try to access
the _B_ookmarks menu item you can't because this page has an accelerator for
"Bug XXXXX _b_locks []". So now you are doubled cursed. What is the correct UI
interpretation of overlapping accelerator keys on a page and in a menu?

Comment 3

15 years ago
For everyone else who is driven nuts by this behavior, here's a quick hack to
fix the accesskey conflicts:
1) Extract chrome/browser.jar (it's a zip archive)
2) Apply the (tiny) attached patch to the resulting content/ directory
3) Zip up the content directory to replace browser.jar

The patch removes the accesskeys for Bookmark This Page, Manage Bookmarks, and
Open In Tabs.  The new behavior is in agreement with the bug submitter's
"Expected Results."

*** This bug has been marked as a duplicate of 147267 ***
Severity: normal → minor
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: Keyboard shortcuts on bookmarks starting with B or M don't work → Keyboard shortcuts on bookmarks menu starting with B or M cause folders starting with B or M to be ignored
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.