Print dialog blocks some events

RESOLVED WORKSFORME

Status

()

Core
Event Handling
--
major
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: pt, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs-CZ; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs-CZ; rv:1.7) Gecko/20040616

If you open more then one window (doesn't matter if it is browser or mail) and
open open print dialog from one of them, other windows seems te be working, but
thay lack. Lack means - that they don't respond to user actions - like 'go to
URL', 'offer visited URLs when writing to address bar' and so. Thay don't lack
UI actions like 'create new tab page' and so.

Reproducible: Always
Steps to Reproduce:
1. Open more than one browser window.
2. Open print dialog on one of them.
3. Switch to another window and write new address, then just press Enter.

Actual Results:  
Browser doesn't retrieve page data from server.

Expected Results:  
Nothing.

Feel free to contact me on - pt@dti.cz - in case of advise or whatever.

Comment 1

14 years ago
Confirming with Mozilla 1.8a5 2004102805 on WinNT4. 

Networking is not completely blocked, only auto-complete and opening pages from
URL bar. You can use bookmarks. So it is not bug 74331.

Is Bug 143359 related?

Comment 2

14 years ago
(In reply to comment #1)
> Networking is not completely blocked, only auto-complete and opening pages from
> URL bar. You can use bookmarks. So it is not bug 74331.

Hmm ... at present it looks related to bug 74331. Behavior has changed with 1.8x.

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 4

13 years ago
Confirming. I can reproduce this with firefox 1.5b1 (Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4). Sample narrative:

1) Open two windows, A and B.
2) In window A, select File->Print to open the print dialog.
3) In window B, type "www.mozilla.org" into the URL bar & hit <enter>

Expect: www.mozilla.org loads and URL bar changes to "http://www.mozilla.org"
Actual: www.mozilla.org loads, but text in URL bar doesn't change.

4) In window B, hit ctrl-T to open a new tab.

Expect: New tab opens, URL bar blanks (my pref is for new tabs to be blank)
Actual: New tab opens but URL bar continues to display "www.mozilla.org".

5) Type "www.slashdot.org" into the URL bar and hit <enter>.

Actual: As before, www.slashdot.org loads, but "http://" isn't added to URL bar.

6) Click on the www.mozilla.org tab to switch tabs.

Expect: The window switches tabs.
Actual: Nothing happens.

7) Close window A's print dialog.

Actual: All of the URL bar changes and tab switches happen at once.
Status: UNCONFIRMED → NEW
Component: Printing → Event Handling
Ever confirmed: true
Summary: windows lack if print dialog is opened → Print dialog blocks some events

Comment 5

13 years ago
Sorry for the spam. I meant to add that the the print dialog blocked URL bar
autocomplete for me, as mentioned in comment 1. Also, I use the flashblock
extension, and it was nonfunctional during the test. A flash object on slashdot
loaded and displayed without any interferance from the extension.

Updated

13 years ago
Assignee: printing → events
QA Contact: ian

Comment 6

13 years ago
*** Bug 294587 has been marked as a duplicate of this bug. ***
Assignee: events → nobody
QA Contact: ian → events

Comment 7

8 years ago
I don't belief this occurs any more
=> WFM
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.