Livemark feature does not reset when going to page without livemark after setting livemark

RESOLVED FIXED

Status

()

P4
normal
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: ubuntu, Assigned: vlad)

Tracking

({fixed-aviary1.0})

unspecified
x86
Windows XP
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+

If you visit a site with a livemark link (e.g. http://news.bbc.co.uk) and set
the livemark using the bolt, the next site you visit without a livemark (even
opening a blank tab) will let you click in that area (although no bolt icon is
there) and set a livemark, which will point to the original feed (although the
title of the new feed will be the current page).

Reproducible: Always
Steps to Reproduce:
1.  Go to page with livemark, and set livemark up from that site (using bolt icon).
2.  Go to page without livemark, click on statusbar where bolt should be, and
setup livemark for that site
3.  Compare in Bookmarks and you will see both livemarks point to the same
(first) feed.

Actual Results:  
Two livemarks in bookmark manager, with different titles, but they point to the
same feed, the original one set.

Expected Results:  
Not allowed a feed to be setup on the site that did not have one.
Assignee: p_ch → vladimir
The patch in bug 250716 seems to have changed how the status bar icons are
displayed to the user; I'll fix livemarks when I get clarification from ben on
what the intended new usage is.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

15 years ago
Flags: blocking-aviary1.0?
Created attachment 153261 [details] [diff] [review]
livemarks-no-feed-no-popup-0.patch

Don't display a popup and change the tooltip if no feeds are available.  I
don't like the wording on the tooltip text; suggestions welcome.

Comment 3

15 years ago
"Bookmark RSS feed on this page as Livemark" is a bit awkward. Questions and
suggestions...

Are we saying a Livemark is a Bookmark, or is it a different thing that lives
with bookmarks? If bookmark can be a verb, then can Livemark? Do we need to say
"RSS" (do/will we support RDF/Atom?)? Are we trying to explain just the action
or do we need to try and make it comprehensible for someone that doesn't know
what Livemarks and feeds are?

How about:
"Bookmark this page's feed as Livemark"
"Add Livemark for RSS feed on this page"
"Add Livemark for this page's feed"
"Add Livemark for this page"

I'd be inclined to use the last one, and drop RSS from the no livemarks one.
Could mention Livemark in the other text:
"Page has no feeds for Livemark"
(Reporter)

Comment 4

15 years ago
(In reply to comment #3)
> "Bookmark RSS feed on this page as Livemark" is a bit awkward. Questions and
> suggestions...
> 
> Are we saying a Livemark is a Bookmark, or is it a different thing that lives
> with bookmarks? If bookmark can be a verb, then can Livemark? Do we need to say
> "RSS" (do/will we support RDF/Atom?)? Are we trying to explain just the action
> or do we need to try and make it comprehensible for someone that doesn't know
> what Livemarks and feeds are?
> 
> How about:
> "Bookmark this page's feed as Livemark"
> "Add Livemark for RSS feed on this page"
> "Add Livemark for this page's feed"
> "Add Livemark for this page"
> 
> I'd be inclined to use the last one, and drop RSS from the no livemarks one.
> Could mention Livemark in the other text:
> "Page has no feeds for Livemark"


I like Michael's "Add Livemark for this page" and perhaps "This page has no
Livemark available" for the other tooltip.  Just a thought.

Comment 5

15 years ago
Howsabout:
Add Livemark for this page's syndication format
Page has no recognized Livemark syndication format

Updated

15 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Priority: -- → P4
syndication format is irrelevant to users, and it'd be confusing wording.  I
think Michaell's suggestion is pretty good, and certainly better than the RSS
bit (especially since we support atom.xml feeds, which aren't RSS ;))
I like Michael's suggestions as well; as for getting rid of "RSS".. well, I
think users know the various syndication formats as "RSS" -- whether they're RSS
0.9/1.0 (RDF), RSS 0.91/0.92/2.0 (XML), or Atom.  (See "Safari RSS" for more
evidence :)  But if we can avoid saying RSS, that's even better.

I think "Add Livemark for this page's feed" and "Page has no feeds for Livemark"
are probably the best way to go. 

Comment 8

15 years ago
"Syndication format" or "syndication feed" can't be irrelevent -- it IS what's
being referenced here -- although it might be meaningless. Using "feed" only, as
suggested (theoretically to be more meaningful), ironically requires the user to
already understand the feature to actually convey meaning. The term syndication,
however, regardless of having four syllables and perhaps being meaningless to
average folks, isn't necessarily jargon (it does have meaning outside of an
Internet context) and its definition can give some clue about this feature. So I
don't agree that it's irrelevent or that it hinders users.  It's harmless to
those who already know and helpful to those who don't.
Comment on attachment 153261 [details] [diff] [review]
livemarks-no-feed-no-popup-0.patch

Patch is fine, as far as it goes.  I could see a "What's a Livemark?" entry
below the list of feeds, or as text in the livemark entry dialog, as a means of
educating the user.  This is fine with whatever wording you decide on, or we
can update the wording later.
Attachment #153261 - Flags: review?(bugs) → review+
in on aviary
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
Just a question
1. I visit www.mozilla.org (livemark popup appears)
2. In the same browser tab, I go to www.google.com ( livemark popup disappears
as expected.
3. If STILL in the same browser tab, I revisit www.mozilla.org again, will the
livemark popup appear again?
(In reply to comment #11)
> Just a question
> 1. I visit www.mozilla.org (livemark popup appears)
> 2. In the same browser tab, I go to www.google.com ( livemark popup disappears
> as expected.
> 3. If STILL in the same browser tab, I revisit www.mozilla.org again, will the
> livemark popup appear again?

Yes.

Comment 13

15 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > Just a question
> > 1. I visit www.mozilla.org (livemark popup appears)
> > 2. In the same browser tab, I go to www.google.com ( livemark popup disappears
> > as expected.
> > 3. If STILL in the same browser tab, I revisit www.mozilla.org again, will the
> > livemark popup appear again?
> 
> Yes.
> 

It doesn't reappear in the 20040717 branch build.

(In reply to comment #13)
> (In reply to comment #12)
> > (In reply to comment #11)
> > > Just a question
> > > 1. I visit www.mozilla.org (livemark popup appears)
> > > 2. In the same browser tab, I go to www.google.com ( livemark popup disappears
> > > as expected.
> > > 3. If STILL in the same browser tab, I revisit www.mozilla.org again, will the
> > > livemark popup appear again?
> > 
> > Yes.
> > 
> 
> It doesn't reappear in the 20040717 branch build.

I can't reproduce it not appearing in either 20040717 or my local build.  Please
 file a new bug, with OS/etc. info..

Updated

15 years ago
Keywords: fixed-aviary1.0
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.