First blocked popup no longer brings up popup blocking dialog

VERIFIED INVALID

Status

()

Firefox
General
--
blocker
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: tracy, Assigned: Blake Ross)

Tracking

({regression, smoketest})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrunner, URL)

(Reporter)

Description

14 years ago
seen on Mac and Windows Firefox 0.9 branch builds from 0712

-launch with a new profile
-Go to www.cnn.com

tested results:
No popup blocking dialog appears. The blocked popup icon appears in the status bar.

Expected results:  
Since this is the first time this profile has encountered a site with a popup,
the popup blocking dialog should appear.  After clicking okay to the dialog, the
blocked popup icon should then appear in the status bar.
(Reporter)

Comment 1

14 years ago
testrunner smoketest case added to URL
Whiteboard: testrunner

Comment 2

14 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712
Firefox/0.9.1+ (Steffen).
It's not a dialog anymore, it's a notification bar below the tabbar. It reads:
"Firefox prevented this site from opening a popup window. Click here for options..."
On leftclick, a context menu opens, where you can allow popups for that site,
edit popup blocker options, choose to not show this message, and pick a popup
you want to show.

Ben changed this with checkins from 2004-07-11 00:58, 2004-07-11 14:39, and
2004-07-11 18:38.

The smoketest needs to be adjusted.
This is not a blocker - it is in fact operating as-designed. The browser
notification replaces the first time informational dialog, which was intended to
help locate the tiny icon. The first time the user disables the browser
notification, the dialog displays then, telling them where the tiny icon is. You
can adjust your test plans accordingly. This is INVALID. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Updated

14 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

14 years ago
Okay.  I'll adjust the relative test cases.
You need to log in before you can comment on or make changes to this bug.