Closed Bug 251069 Opened 19 years ago Closed 19 years ago

ignores the <col> XHTML1.1 tag when renders tables

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 915

People

(Reporter: bugzilla, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

In the page at http://www.borfig.com/firefox.html, all 3 cells of the left
column are to be right-aligned, and this was defined with the <col> tag inside
the <table> tag. Mozilla Firefox v0.9.2 is (possibly) ignoring the <col> tag.

Reproducible: Always
Steps to Reproduce:
Option A:
1. Write the following XHTML1.1 code in a page:
<table border="0" width="100%">
<col align="right" />
<tr>
 <th>Short on Right:</th><td>Short on Left</td>
</tr><tr>
 <td>Short on Right:</td><td>Short on Left</td>
</tr>
<tr>
 <th>Lo-o-o-ng on Right:</th><td>Lo-o-o-ng on Left</td>
</tr>
</table>
2. Launch Mozilla Firefox v0.9.2 to open this file.
Option B.
Let Mozilla Firefox v0.9.2 navigate to http://www.borfig.com/firefox.html

Actual Results:  
The cells of the left column are rendered incorrently (<th> is centered and <td>
is left-aligned), although the <col> tag specifed otherwise.

Expected Results:  
The cells of the left column are expected to be rendered right-aligned as as
speficied by the <col> tag.

*** This bug has been marked as a duplicate of 915 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.