Last Comment Bug 251101 - Per-extension buttons (Options, Info, Home) never take focus
: Per-extension buttons (Options, Info, Home) never take focus
Status: VERIFIED INVALID
: access, sec508
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: unspecified
: All All
: -- major (vote)
: ---
Assigned To: Jesse Ruderman
: Ben Goodger (use ben at mozilla dot org for email)
: Andy McKay [:andym]
Mentors:
Depends on:
Blocks: firekey
  Show dependency treegraph
 
Reported: 2004-07-12 16:47 PDT by Jesse Ruderman
Modified: 2008-07-31 01:49 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jesse Ruderman 2004-07-12 16:47:17 PDT
 
Comment 1 Jarrod Lee Petz 2004-07-17 05:39:53 PDT
The Title says it all. But I thought Id add a long description.

Steps to reproduce
1. Open the tools menu and select the extensions manager
2. In tha manager click on an extensions icon. Preferably one that brings up a
window when you click on options(Such as AutoHide, Adblock and Tabbrowser
Preferences).
3. Now click on the options button for a different extension.

=> Expected Results
Focus is moved to the extension select in step 3 and its options screen is
brought up.
=> Actual Results
Focus remains on the extension you selected in step 2. Then the options window
for the extension in step 2 is brought up. Once that options windows is close
focus is then moved to the extension clicked on in step 3.
Comment 2 Jesse Ruderman 2004-07-17 12:34:40 PDT
Jarrod: that's not what I meant by this bug.  That will teach me to enter bugs
without long descriptions :)

What I meant was:

1. Open Extension Manager.
2. Hit Tab a few times.

Result: Options, Info, Home buttons never receive focus.
Comment 3 Jarrod Lee Petz 2004-07-19 01:41:36 PDT
Jesse: Sorry for highjacking you bug report. Id guess both problems are occuring
because of similar faults in the code. Hopefully both will get fixed at the same
time.
Comment 4 Jesse Ruderman 2004-08-25 23:05:34 PDT
Aaron, what should we do with per-list-item buttons?  Some possibilities:

A. Put them in the tab order.  (Would tabbing through the buttons change which
extension is selected?)
B. Put them in the tab order, but only for the selected extension.
C. Leave them out of the tab order, forcing keyboard-only users to use the
context menu.
D. Turn them into normal buttons outside of the list.
Comment 5 Aaron Leventhal 2004-08-26 04:56:50 PDT
(In reply to comment #4)
> Aaron, what should we do with per-list-item buttons?  Some possibilities:
> 
> A. Put them in the tab order.  (Would tabbing through the buttons change which
> extension is selected?)
> B. Put them in the tab order, but only for the selected extension.
> C. Leave them out of the tab order, forcing keyboard-only users to use the
> context menu.
> D. Turn them into normal buttons outside of the list.

I would be okay with D, but Ben doesn't want that one. I think B would be the
second best for accessibility -- good enough.

Comment 6 sairuh (rarely reading bugmail) 2004-08-26 09:13:59 PDT
option (B) also sounds good to me.
Comment 7 Ryan Polk (Quark) 2004-09-01 16:07:39 PDT
As Ben mentioned in bug 257677, Home and Info are now context menu only, options
is down with Update and Uninstall.

Note You need to log in before you can comment on or make changes to this bug.