unreasonable slowdown with javascript animation of transparent gif DIV layers

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Jeff Lyon, Unassigned)

Tracking

({perf, testcase})

1.0 Branch
x86
Windows XP
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

This page is supposed to smoothly scroll multiple layers of transparent GIF div 
elements. It worked properly in Firefox 0.8 and Internet Explorer 6.

In Firefox 0.92 it is horribly slow, but functional. Can you tell me if there 
is any way to work around this? It's a major bummer.

Reproducible: Always
Steps to Reproduce:
1. go to the page in firefox 0.92. note the slowness.
2. try it again in firefox 0.8. much faster, eh?
Actual Results:  
the page runs slowly.

Expected Results:  
the page should run at least as fast as it did in firefox 0.8...

can you please contact me regarding this? i don't know what to do to fix my 
page in 0.92!

Comment 1

13 years ago
Reporter,

the link you provided does not work anymore. Could you provide a new url?

Updated

13 years ago
The url testcase is slow for me in Mozilla1.7, but quite fast/normal in the
latest Firefox trunk build.
I think this is WORKSFORME.
Possibly fixed by bug 284716. 

Updated

12 years ago
Component: General → Layout
Keywords: perf, testcase
Product: Firefox → Core
Version: unspecified → Trunk

Updated

12 years ago
Assignee: firefox → nobody
QA Contact: general → layout

Comment 3

9 years ago
Works equally for me across browsers.

CPU usage spikes at 100% with this, so I think this is a question of hardware and not of software.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Opera 9.60 doesn't give an cpu usage spikes for me at all with the testcase, so it seems to me that Firefox still could do a lot better here.

Comment 5

9 years ago
My other PC with a more modern Core 2 Duo reaches about 70% with bot, Opera 9.6 and Firefox 3. Firefox' animation is more smooth though.
(Reporter)

Comment 6

9 years ago
Wow, I filed this more than four years ago. I'm pretty sure it is fixed now though. I was able to produce the problem in both Windows and Linux, and then mysteriously the problem stopped happening after one of the patches. Whatever was broken in 0.9.2 has long since been fixed...

I would agree with closing this one. Thanks guys.
Component: Layout → General
Product: Core → Firefox
Resolution: WORKSFORME → FIXED
Version: Trunk → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.