Normal table inside floated fieldset display incorrectly

RESOLVED DUPLICATE of bug 129346

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 129346
14 years ago
4 years ago

People

(Reporter: steven, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

With the following code inside a blank HTML document:

<fieldset style="float: left;">
The columns of this table should line up:
<table border="1">
 <tr><td>A A A</td><td>B B B</td><td>C C C</td></tr>
 <tr><td>A A A A A</td><td>B B B B B</td><td>C C C C C</td></tr>
</table>
</fieldset>

The table looks bad: the columns do not line up, as if every cell had float:
left; applied to it. Changing the fieldset to a div or paragraph removes the
buggy behaviour. Trying to use CSS to explicitly revert the table and its cells
back to float: none; has no effect.

Reproducible: Always
Steps to Reproduce:
1. Just use the snippet of HTML code above.

Actual Results:  
The table cells are misaligned, as if all cells had float: left; applied to them.

Expected Results:  
The table should have normal layout with all columns aligned.

The CSS float property is not inherited, so the fieldset's floatyness should not
affect anything inside it.
(Reporter)

Comment 1

14 years ago
Created attachment 152997 [details]
Complete HTML file with example

Here's an HTML file which illustrates the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Known bug in the shrink-wrap impl of fieldsets...

*** This bug has been marked as a duplicate of 129346 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.