All users were logged out of Bugzilla on October 13th, 2018

Bookmark toolbar folders shouldn't open all bookmarks when dragged into window.

RESOLVED DUPLICATE of bug 201898

Status

RESOLVED DUPLICATE of bug 201898
15 years ago
14 years ago

People

(Reporter: neilio, Assigned: mikepinkerton)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040712 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040712 Camino/0.8+

I did a search but couldn't find a matching bug for this, but it's been driving
me nuts for quite some time. If you accidentally drag and drop a folder into the
browser window, Camino opens all of the bookmarks inside of that folder in new tabs.

I have accidentally clicked and drag / dropped a folder into the window more
times than I care to count - the folders in the toolbar are /incredibly/
sensitive. Could either this behavior be turned off (i.e. dragged bookmark
folders don't open in new tabs), or made "less sensitive" so that accidental
click drags don't cause a flood of tabs to open?

Note: this is especially bad when using a Wacom tablet as the primary pointer -
clicking on the tablet will often accidentally click and drag the folder.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Dup of Bug 243720?
(Assignee)

Comment 2

15 years ago
i think this is a dupe of a bug that jasper filed. really we should fix the "too
easy to drag by accident" behavior, rather than the end behavior which makes sense.

jasper, can you dupe this if it's the same?

Comment 3

15 years ago
There are a coouple of things on my mind.

1. the behaviour as described by me in Bug 201898 will defenitly help people get
less nurvous of bookmark folder dragging.
2. there should be a way to stop dragging bookmark bar folders, by hitting the
Escape key for instance.
3. Some how I still prefer not to be able to drag and drop folders in the page
view. Implementing Bug 174822 will still allow us to easily open folder
contetnts in the page view but will make it les dangerous as exedantaly dragging
a folder CAN CRASH camino.

So it's a complex thing we should talk about.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 201898 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.