dom.disable_window_status_change only partially works

RESOLVED DUPLICATE of bug 40838

Status

()

Core
DOM: Core & HTML
--
minor
RESOLVED DUPLICATE of bug 40838
14 years ago
14 years ago

People

(Reporter: Dave Evans, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.1) Gecko/20040707

When dom.disable_window_status_change is true (and Javascript is enabled), I
expect that the window status text should behave exactly as it would when
Javascript is disabled.  But it does not.

Consider the above cited URL.  On the right there are Google sponsored links,
including (for me) one which says "eBay UK. Official Site".  It has
"onmouseover" code which sets window.status to a message, and onmouseout which
blanks it again.

(1) When Javascript is enabled, and dom.disable_window_status_change is false,
then hovering over the link shows the message ("Go to ebay").

(2) When Javascript is disabled, then hovering over the link displays the href
of the link

(3) When Javascript is enabled, but dom.disable_window_status_change is true,
I'd expect the behaviour to be the same as (2).  But instead, we get a third
behaviour: the window status remains blank.

I'm not sure if this is a bug, but it's not what I /expected/ to see anyway.


Reproducible: Always
Steps to Reproduce:
See above
Actual Results:  
See above: the window status remains blank

Expected Results:  
I expected the window status to show the link href

Comment 1

14 years ago
See Bug 40838. Dupe?
(Reporter)

Comment 2

14 years ago
Yup, it's the same problem.  I didn't realise that this
<http://bugzilla.mozilla.org/show_bug.cgi?id=40838#c9> was the case, and I'd
agree with http://bugzilla.mozilla.org/show_bug.cgi?id=40838#c23 completely.

I wonder why I couldn't find #40838, despite searching for
dom.disable_window_status_change?  Oh well.

Thanks for spotting the dupe for me.


*** This bug has been marked as a duplicate of 40838 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.