MailNews should automatically encrypt if recipient's certificate is present

RESOLVED DUPLICATE of bug 135636

Status

--
enhancement
RESOLVED DUPLICATE of bug 135636
15 years ago
10 years ago

People

(Reporter: stupiddog, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.7.1) Gecko/20040707

I would like to see the following feature:

If I compose a mail, and for every recipient, I also have a public certificate
in my store, MailNews should prompt me if I want to encrypt the mail. 

Why would this feature be useful? Because most of my communication partners
(about 95%) do not have email certificates, so having the "encrypt" option
always turned on is not very handy (an error message pops up everytime I have a
recipient in my list for who I do not have a public cert). 

Reproducible: Always
Steps to Reproduce:
bug 135636 does what you want, I think

*** This bug has been marked as a duplicate of 135636 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.