option to terminate scripts spawning "alert" or "confirm" dialogs

VERIFIED DUPLICATE of bug 61098

Status

()

Core
JavaScript Engine
--
enhancement
VERIFIED DUPLICATE of bug 61098
14 years ago
11 years ago

People

(Reporter: Felipe, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

Could "alert" and "confirm" dialogs have an option to terminate the script? Or
am I the only programmer who would like to be able to stop a script that is
incessantly displaying these things, sometimes in the thousands?

Reproducible: Always
Steps to Reproduce:

Updated

14 years ago
Assignee: firefox → general
Component: General → JavaScript Engine
Product: Firefox → Browser
QA Contact: firefox.general → pschwartau
Version: unspecified → Trunk

Comment 1

14 years ago
Changing summary
Summary: simple, helpful Javascript feature request → option to terminate scripts spawning "alert" or "confirm" dialogs

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 61098 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.