Closed Bug 251231 Opened 20 years ago Closed 17 years ago

View source does not show content of currently displayed page if this page was changed and loaded in another instance of browser

Categories

(Toolkit :: View Source, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 136633

People

(Reporter: mcv, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

If two windows of FireFox contains two copies of the page  - one fresh, changed
and one old, previosly loaded - the ViewSource called from "old" window will
show the source of FRESH page, but not the page that displayed in this window.

Reproducible: Always
Steps to Reproduce:
1. Create simple html file on your disk: <html>1</html>
2. Load it in Firefox
3. CHange and save page: <html>2</html>
4. Load it again in new window
5. Do "ViewSource" in old window


Actual Results:  
ViewSource showing: <html>2</html> 

Expected Results:  
<html>1</html> i.e. source of html page which displayed in this window
This is because View Source is loading the page source from cache, and cache
entry is replaced when a newer page is loaded from the same URL.

While it is a bug from user's POV, it won't be fixed anytime soon, as it
requires changes to caching system.

recommend wontfix
this is a realy stupid . 
as a webmaster  i offten need to see what happend with stupid html in dynamic
created page but i see only current state. 
If i have page with form which submit to itself and there are PHP script for
example view source shows source for page before submit but firefox displays
page with contents after submit. 
stupid.
Additionally, when interacting with an application server like Tomcat, which
uses redirects (or something similar) to login pages for protected resources,
"View Source" shows the source for the login page, rendering the feature
completely useless.

Mozilla 1.7.5 gets this right...
Note bug 288462.
Blocks: 288462
The block on 288462 doesn't make any sense.

This is about stale caching. I.E. old versions of the page in view source rather
than the current one, not about the history mechanism or anything else referred
to in 288462.

As noted previously, mozilla gets this behavior correct (to the end user) even
if it possibly executes in incorrectly.
No longer blocks: 288462
> This is about stale caching. I.E. old versions of the page in view
> source rather than the current one,

No, it's not about stale caching.  You have it backwards.  Read
this report again.  

It's about NEW source data in the source window instead of the 
source of OLD data in the window from which View Source command 
was invoked:

  If two windows of FireFox contains two copies of the page  - one 
  fresh, changed and one old, previosly loaded - the ViewSource 
  called from "old" window will show the source of FRESH page, but 
  not the page that displayed in this window.


> The block on 288462 doesn't make any sense.

Yes it does.  This bug is another case of making a new request to 
the server instead of using the already-retrieved data, which is
exactly what 288462 is about.


Please do NOT throw away data (my marking these bugs as related)
and waste effort (my searching through dozens or hundreds of
bug reports to collect the ones related to 288462) unless you're 
sure.
Blocks: 288462
> You have it backwards.

You are correct, I did have it backwards. Sorry!
I also say this is a bug.
Addition: if I want to view the source of a page which is the result of a posted
form, upon View source the page is posted again.
I don't want View source to post my forms, I want it to show the source of what
I see in the browser.
(In reply to comment #1)
> This is because View Source is loading the page source from cache, and cache
> entry is replaced when a newer page is loaded from the same URL.

see Bug 55583

Summary: View source does not showing content of curriently dislayed page if this page was changed and loaded in another instance of browser → View source does not showing content of currently dislayed page if this page was changed and loaded in another instance of browser
This is also reported as Bug 307089.
Please, FIX THIS.

This bug is a MAJOR ISSUE for anyone doing web/cgi development - variables/states change with every page request, and if view source is unreliable, the browser becomes worse than useless, it becomes completely untrustworthy.
Bugs I've found to date relating to this:
Bug 251231
Bug 306916
Bug 307089
Bug 321291
Bug 340120

I'll bet there are more - this was simply a search in Bugzilla for "view source". 
Assignee: bugs → nobody
Flags: blocking1.8.0.14?
Summary: View source does not showing content of currently dislayed page if this page was changed and loaded in another instance of browser → View source does not show content of currently displayed page if this page was changed and loaded in another instance of browser
Flags: blocking1.8.0.14? → blocking1.8.0.14-
This is exactly the same as 136633
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.