Comments in HEAD are moved

VERIFIED FIXED in M18

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: rubydoo123, Assigned: Akkana Peck)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
using build 200001252 on win95
1. create an HTML with this as the content:
<HTML>
<HEAD>
<!-- comment 1 -->
<!-- comment 2 -->
<!-- comment 3 -->
<TITLE>Test File</TITLE>
</HEAD>

<BODY>
<P>I'm a little paragraph.</P>
</BODY>
</HTML>

2. display file in the browser
3. check out the content tree -- the comments are within the head
4. check out the xif output -- the comments are within the head
5. check out the html output -- the comments are between <HTML> and <HEAD>
6. select File|Save page as, save the file and look at the source -- the 
comments are in the correct spot
7. go back to the browser, this time select File|Edit page
8. in the editor, select File|Save as, save the file and look at the source -- 
the comments are now between the <HTML> element start tag and the <HEAD> element 
start tag

somehow, the save from within the browser is picking the output up from the 
content tree, in the editor it seems like the output is picked up from the html 
output

I think this is a parser issue, but if I'm wrong please reassign.
(Reporter)

Comment 1

18 years ago
talked with harish about this one this morning, assigning to harish
Assignee: rickg → harishd

Updated

18 years ago
Target Milestone: M18

Comment 2

18 years ago
Akkana, this sounds like HTMLContentSinkStream issue...I guess.
Assignee: harishd → akkana
(Assignee)

Comment 3

18 years ago
Created attachment 7231 [details]
Attachment to make it possible to test
(Assignee)

Comment 4

18 years ago
I can't reproduce this.  But I think there are steps missing, e.g. step 1 says
use the browser window, but steps 2-5 are only available (I think?) in the
editor window, so I'm not sure where to do step 6.  I spent a while horsing
around with loading and saving this file in both the browser and editor, and
never managed to get the comments to move from the head into the body.
(Reporter)

Comment 5

18 years ago
actually we looked at the 3 sources through the debugger if I remember 
correctly. In any event I tried this out using the 4 APR build and the comments 
are not being moved between the <HTML> and <HEAD> elements. Marking fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Comment 7

17 years ago
Verified on:
build: 2001-07-02-04-Trunk
platform: WinNT

1. Opened the test case in the browser and did 'View Source' the comments were 
between head and title.
2. Did 'File|Edit page', the comments are in between head and title.

Both are desired results.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.