Download manager loads slowly with large history list

RESOLVED DUPLICATE of bug 161783

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 161783
14 years ago
10 years ago

People

(Reporter: kenno, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I have installations of firefox 0.8 and 0.9.x on various PCs ranging from
Pentium I to Pentium III, and the download manager consistently needs one or two
seconds to pop up. It's not long, but it's way too much, considering that one
usually is eager to do something with the download. I feel that the download
manager should pop up lightning-fast, even if that involves loading it into
memory when firefox starts up, thereby increasing memory requirements en startup
time.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Sorry, I submitted a wrong Build Identifier. It should of course be Firefox/0.8
and Firefox/0.9.x
(Reporter)

Comment 2

14 years ago
Update: the cause of the problem was identified as being the huge download
manager history list that accumulates when one puts "Remove files from the
download manager" on "manual" (in my specific case, the list was inherited from
firefox 0.7). I suggested a possible workaround in bug 251337, which would at
the same time be an improvement in general.

Was it appropriate to mark this bug as "dependent on bug 251337", or does that
signify something else?

I'm aware that I've hassled you guys quite a lot these days with download
manager rants, but I really have issues with this feature, and I figured, since
you are unwilling to provide even an option to remove it, better try to do
something about the issues themselves ;-)
Depends on: 251337
(Reporter)

Updated

14 years ago
Summary: Download manager loads slowly on older computers → Download manager loads slowly with large history list

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 161783 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.