No tooltip for "From:" in collapsed/brief header if sender isn't in Address Book

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Ben Ruppel, Assigned: Žiga Sancin)

Tracking

({fixed1.8.1})

Thunderbird2.0
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.35 KB, patch
Scott MacGregor
: review+
Scott MacGregor
: superreview+
Scott MacGregor
: approval-thunderbird2+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
In the 3-pane view, when the header in the message pane is collapsed, only the
"friendly" name of the message sender is shown after "From:"

It would be very nice if there was a tooltip for this name that showed the
sender's email address.  Right now, one would have to expand the header or copy
the email address using the name's context menu.

It was fixed back in 2002 for the suite, see bug 90368.  Maybe someone could use
that patch code.
http://bugzilla.mozilla.org/show_bug.cgi?id=90368

Comment 1

14 years ago
I have the same problem, but not just limited to three column view

Comment 2

14 years ago
This works for me with TB 1.0, Win2K.  Ben Ruppel, if you also see this working 
as expected, please mark this bug:   Resolved | WorksForMe
(Reporter)

Comment 3

14 years ago
Mike, I apologize but I am not at a computer where I can confirm or deny this 
and I won't be until Jan 3.  I will mark this bug resolved or respond otherwise 
on that date.

Comment 4

14 years ago
No response from reporter; =>WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

14 years ago
(In reply to comment #4)
> No response from reporter; =>WFM

Nope, just tried it with Jan 29 trunk build and it is still broken.  Excuse me
for forgetting to respond.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

14 years ago
Oh crud, sorry Mike.  This works for me, I wasn't checking for the tooltip properly.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

14 years ago
No, wait!  It seems to work, but only for email addresses in my address book. 
So when I get emails from people I know their addresses show up as tooltips, but
when I get emails from people not in my address book there is no tooltip.  For
example, an email from Verizon does not have a tooltip showing the sender's true
address because that address is not in my address book. 

I will open this.  Let me know if I should change the summary or file a
different bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

13 years ago
This is also a problem if the sender is in, say, the Collected Addresses.

See bug 305204.
Component: General → Mail Window Front End
OS: Windows XP → All
Hardware: PC → All
Summary: Name shown after "From:" in collapsed header of message pane should have email address as tooltip → No tooltip for "From:" in collapsed/brief header if sender isn't in Address Book
Version: unspecified → Trunk
(Assignee)

Comment 9

13 years ago
Created attachment 209776 [details] [diff] [review]
patch

The if statement is far too restrictive... The function useDisplayNameForAddress(); returns false for addresses that are not in the Personal AB, so these addresses don't get the tooltiptext attribute. We should move the function out of the if statement.
Attachment #209776 - Flags: review?(mscott)
(Assignee)

Comment 10

13 years ago
Oops, not out of the if statement, just out of the conditions...

Comment 11

12 years ago
*** Bug 241763 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
Scott, could we get this simple patch reviewed, pls?

Comment 13

12 years ago
Comment on attachment 209776 [details] [diff] [review]
patch

sure!
Attachment #209776 - Flags: superreview+
Attachment #209776 - Flags: review?(mscott)
Attachment #209776 - Flags: review+

Updated

12 years ago
Attachment #209776 - Flags: approval-thunderbird2+

Comment 14

12 years ago
Gavin might be able to check this in for you. 
Whiteboard: [checkin needed]
Assignee: mscott → bisi
Status: REOPENED → NEW
mozilla/mail/base/content/msgHdrViewOverlay.js 	1.56.2.19
mozilla/mail/base/content/msgHdrViewOverlay.js 	1.78
Status: NEW → RESOLVED
Last Resolved: 14 years ago12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Thunderbird2.0
Version: Trunk → 2.0

Comment 16

12 years ago
oops, I think this patch broke: Bug 348860.

Updated

12 years ago
Depends on: 348860
You need to log in before you can comment on or make changes to this bug.