ssl-icon should open their windows with a single click, not a double click

RESOLVED DUPLICATE of bug 432741

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED DUPLICATE of bug 432741
14 years ago
9 years ago

People

(Reporter: Norbert, Unassigned)

Tracking

({polish, ue})

Trunk
polish, ue
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

There are such icons displayed at the bottom/left. For example the icon that
popups have been blocked or that a https-site is loaded. There are also other
icons ...

But they behave inconsistent:
The https-icon has to be double-clicked to open it's window, while the
popup-icon only needs a single click. I have not tested the other icons.

All icons should open their window with the same amount of clicks! I suggest a
single click for all icons.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Updated

14 years ago
Summary: https-icon needs a double-click to open while popup-icon only a single click → the https-icon needs a double-click to open it's window while the popup-icon only a single click
I cannot confirm this behavior in MacOS X using "Mozilla/5.0 (Macintosh; U; PPC
Mac OS X Mach-O; de-DE; rv:1.7) Gecko/20040628 Firefox/0.9.1". 
For me, the "https" and the "popup"-icon need a double click, which is annoying.
A single click would be much more intuitive.
I will test this in Windows, too, and see if I can confirm this bug.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
 
> For me, the "https" and the "popup"-icon need a double click, which is annoying.
> A single click would be much more intuitive.
You are right. Both need double click. It was my mistake, sorry.

But I agree that single clicks would be better. I will correct the summary and
the severity.
Severity: normal → minor
Summary: the https-icon needs a double-click to open it's window while the popup-icon only a single click → icons (like the https-icon or the popup-icon) that are shown at the bottom right should open their windows with a single click, not a double click
(Reporter)

Updated

14 years ago
Summary: icons (like the https-icon or the popup-icon) that are shown at the bottom right should open their windows with a single click, not a double click → icons (like the https-icon or the popup-icon) that are shown at the bottom left should open their windows with a single click, not a double click
confirming bug, setting HW/OS to All/All,
slight modification to summary
Assignee: firefox → bugs
Status: UNCONFIRMED → NEW
Component: General → Toolbars
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: firefox.general → bugzilla
Hardware: PC → All
Summary: icons (like the https-icon or the popup-icon) that are shown at the bottom left should open their windows with a single click, not a double click → icons (like the ssl-icon or the popup-icon) that are shown at the bottom left should open their windows with a single click, not a double click
(Reporter)

Comment 4

14 years ago
(icons that already open a pop-up menu on dingle-click (like the RSS-icon)
should be kept as is, in my oppionion.

icons that open a window on double-click should be changed to single-click, in
my oppinion.)

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars
Assignee: nobody → highmind63
Severity: minor → enhancement
Status: NEW → ASSIGNED
Keywords: ue
Version: unspecified → Trunk
Created attachment 383558 [details] [diff] [review]
single click

This should do it. Seems like this makes a lot more sense now that the size of the element is a whole lot smaller (just the icon).
Attachment #383558 - Flags: ui-review?(faaborg)
Attachment #383558 - Flags: review?(johnath)
Updating summary to reality. ssl icon is shown on the right (at least in ltr builds) and the pop blocker icon is now a button that opens a menu on single click, so no longer an issue.
Summary: icons (like the ssl-icon or the popup-icon) that are shown at the bottom left should open their windows with a single click, not a double click → ssl-icon should open their windows with a single click, not a double click
Whiteboard: [needs review johnath][needs ui-review faaborg]
Keywords: polish
Natch - see bug 432741 (which we should probably dupe against this one, or vice versa, since that one has more information) - we actually want slightly nicer behaviour here, so that whether a user single- or double- clicks, they only get one copy.  Gavin's suggestion at the end of that bug is probably all it would take - feel like writing an updated patch? I don't care which bug you attach it to, but let's dup off the other one, shall we?
Duplicate of this bug: 496616
Comment on attachment 383558 [details] [diff] [review]
single click

yup, I'll dupe this bug to that one, wasn't aware of the other bug.
Attachment #383558 - Attachment is obsolete: true
Attachment #383558 - Flags: ui-review?(faaborg)
Attachment #383558 - Flags: review?(johnath)
Assignee: highmind63 → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [needs review johnath][needs ui-review faaborg]
Duplicate of bug: 432741
You need to log in before you can comment on or make changes to this bug.