When drag, text becomes selected.

VERIFIED INVALID

Status

()

Core
DOM
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: /\/\arcio Galli, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
200012609 on WinNT 4 SP5.

To reproduce: open URL and drag the blue pane, try dragging very fast over the 
text, moving, etc.

Expected: Just to move the blue pane based on mouse position. 

Actual: See that the background text as well the text over the blue area becomes 
selected. 

Comments: I testing using slow machines it's very easy to observe.

Comment 1

18 years ago
Passing along to mjudge, since he's selection owner.
Assignee: vidur → mjudge
Summary: When drag, text becomes selected. → When drag, text becomes selected.

Comment 2

18 years ago
changing QA contact to eli and setting milestone to m15
QA Contact: vidur → elig
Target Milestone: M15

Updated

18 years ago
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M15 → M16

Comment 3

18 years ago
Using the provided example this is the expected behavor, the scriptor should 
have used event.preventDefault() to prevent the selection of the text. I 
modified the example to use a call to event.preventDefault() and it no longer 
selects the text (http://3wdesigns.simplenet.com/mozillatests/dragdrop.htm). 
This bug should be marked as INVALID.
(Assignee)

Comment 4

18 years ago
so i am marking it invalid now. I concur this does fix the problem.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 5

18 years ago
Rubber-stamping as Verified/Invalid, since I'm not familiar with the subject 
area, and trust mjudge.

Marco, please do re-open if you believe this resolution is in error. (and keep up 
the awesome demos! ;)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

17 years ago
Eli, roger,

do you believe this should be the expected behavior? I believe with Netscape 4.x
this behavior was not happening. Looking for input.
Component: DOM Level 2 → DOM Other
Component: DOM Other → DOM Level 1
You need to log in before you can comment on or make changes to this bug.