Propose meaningful dialogue for connection errors to localhost

RESOLVED DUPLICATE of bug 308982

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 308982
14 years ago
13 years ago

People

(Reporter: bobharvey, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

There has been a lot of traffic about 'conection refused' messages.  See bugs
209284 242137 249246, etc.

These split into at least two types: site specific and universal.  It would
appear that the universal instances are usually associated with wild firewall
setting.  I found this little gem at the end of bug 209284:
> Additional Comment #5 From Andreas Kunz  2004-04-01 11:05 PDT
> Alex, apart from the question if this still happens, 
> one information: 
> Mozilla (and Firefox) connect to the local computer 
> (127.0.0.1) before doing any other connection. Please 
> make sure this connection is not blocked.

How about a separate, more explict, dialogue just for this case?  Something
along the lines of "initial connection to localhost 127.0.0.1 refused.  Probable
firewall configuration problem"

I commend this idea because it would help people understand what was going on,
reduce the amount of traffic in the support channels, and shift the blame from
Firefox to another product, helping with the image of the software.

Reproducible: Always
Steps to Reproduce:




-0-
This will, of course, do nothing to fix the site-specific "connection refused"
problem.
(Reporter)

Comment 1

14 years ago
I've now cross-checked a couple of hundred sites with 'connection refused'
messages and tied almost all of them to ad blocking software making host file
entries to 127.0.0.1  So I've closed my original report 242137.

I am now more convinced than ever that a more explicit message for this case of
127.0.0.1 would have been much more useful.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 3

13 years ago
I don't think auto-resolution is appropriate for enhancement suggestions.
If you want to take up the idea, fine.
If you decided not to, it's your product.  Just decided.

Bob
related to Bug 308982 ?

Comment 5

13 years ago
Reporter, did you check with the latest Firefox 1.5 beta 1 ? Then you would have
seen the new error-pages. Among other things, it tells the user :

    If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.

This is a works for me, although it's doesn't mention the local loop connections
(which only brain-dead firewall software would report as suspicious).
(Reporter)

Comment 6

13 years ago
Hi Jo
No, I don't do betas any more - I have a job as a service engineer and I go
on-line via dialup at hotel analogue phone prices, so downloading doesn't happen.

My original report was just a suggestion to improve usability, and nothing more.
 It was not a data-destroying bug just an unclear situation.  I reckon it's up
to the developers to decide if it is covered to thier satisfaction, not to  me.

This particular machine does exhibit odd behaviour which I put down to a
corporate firewall and that is my problem, not Mozilla's.

Maybe when I am home (if ever) I'll look at 1.5.  Big version number jump, whot?

Comment 7

13 years ago
(In reply to comment #6)
> My original report was just a suggestion to improve usability, and nothing more.
>  It was not a data-destroying bug just an unclear situation.  I reckon it's up
> to the developers to decide if it is covered to thier satisfaction, not to  me.

Then it's probably a duplicate of bug 308982, which wants to educate the user
about the firewall and how to configure it (although it's not Firefox job).

Comment 8

13 years ago

*** This bug has been marked as a duplicate of 308982 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.