Properties dialog for folders that weren't used before is broken (due to 0 byte msf file)

RESOLVED WORKSFORME

Status

MailNews Core
Database
--
minor
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Stefan Borggraefe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Tested with a three day old Linux trunk build.

Steps to reproduce:
1. Right click the "Drafts" folder under "Local Folders"
2. Select "Properties..."

Result:
A broken Properties dialog. All possible widgets and tabs are shown at once
(e.g. you get an Offline tab with two "Download Now" buttons, a "Sharing" tab,
options only applicable to Newsgroups etc.). The JavaScript console shows this
uncaught exception:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80550005 [nsIMsgFolder.charset]"  nsresult: "0x80550005 (<unknown>)" 
location: "JS frame :: chrome://messenger/content/folderProps.js ::
folderPropsOnLoad :: line 204"  data: no]
(Reporter)

Updated

14 years ago
Summary: Properties dialog of Local Folders/Drafts and Local Folders/Templates is broken → Properties dialog of Local Folders/Drafts and Local Folders/Templates are broken
(Reporter)

Comment 1

14 years ago
Forget the steps to reproduce in comment 0. This has nothing to do with the
"Drafts" folder specifically, but this happens with all folders with .msf-Files
of zero length.

When you create a POP3 or Movemail Account and try Properties with a folder you
haven't stored mails in yet, you see the broken dialog. The same happens with
folders in the Local Folders account that weren't used yet.

The only local folder type that doesn't have this bug is the Inbox folder,
because this folder has a .msf file right after the account is created.

When you create a new folder by hand there is always a meaningful msf file
created. So I think it is a bug that this doesn't happen on account creation and
thus this report probably belongs more to Mail Database instead of Mail Window
Front End.

This bug is already present in Mozilla 1.6, so this isn't (at least not a
recent) regression.
Assignee: sspitzer → bienvenu
Component: Mail Window Front End → Mail Database
Summary: Properties dialog of Local Folders/Drafts and Local Folders/Templates are broken → Properties dialog for folders that weren't used before is broken (due to 0 byte msf file)
Product: MailNews → Core
QA Contact: database
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 2

8 years ago
wfm - please re-open if you still see it...
Assignee: bienvenu → nobody
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.