Focus outline is missing when part of the link text is in a <b> tag.

RESOLVED DUPLICATE of bug 250858

Status

--
trivial
RESOLVED DUPLICATE of bug 250858
15 years ago
14 years ago

People

(Reporter: kevinar18, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040711 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040711 Firefox/0.9.0+

If you make part of the text for a link bold (using the <b> tag), and then
mousedown on the part in bold, then the entire URL text does not get selected
(have a dotted border).  Instead only the part in bold has the border.

Reproducible: Always
Steps to Reproduce:
1. Go to
http://www.google.com/search?num=30&hl=en&lr=&ie=UTF-8&safe=active&q=mozilla+firebird&btnG=Search
2. In the first search item/URL list, mousedown on one of the bold items.

Actual Results:  
The bold item is selected (shows the dotted box).

Expected Results:  
The entire URL text should show the dotted box.

Note: This is just a preliminary report.  If possible, I may do some further
testing to see if it occurs with other tags as well.

Comment 1

15 years ago
been seeing this too - wonder if it's related to bug 171366 or one of the fixes
Modifying summary, CC Aaron Leventhal
Summary: Entire link is not selected when part of the link text is in a <b> tag. → Focus outline is missing when part of the link text is in a <b> tag.

Updated

15 years ago
Keywords: regression
Yes, it is related. This bug will probably become a dupe of bug 250858.
See bug 250858, comment 5.

Comment 3

15 years ago
Right. I didn't read all of that bug. Dup'ing.

*** This bug has been marked as a duplicate of 250858 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.