If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

adding sites to popup allow list doesn't result in sites able to open

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Ryan Becerra, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040713 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040713 Firefox/0.9.1+

The new popup bar does not work at all. Even when selecting to allow popups it
continues to block them. The bar is not functional.. (the right click menu
options don't work on the popup bar). All popups end up being blocked even when
they are requested by a user click. (not normally blocked in previous builds)

Reproducible: Always
Steps to Reproduce:
1. Go to a page that opens a popup from a link.
2. The new popup blocker bar will open below the tabs
3. Choose to unblock the site from the new popup bar

Actual Results:  
Notice that even though you have chosen to allow popups, it continues to block them.

Expected Results:  
It should have unblocked the site from being blocked of all popups.

default theme
july 14th branch build
does it work in the 20040713 build ?
(Reporter)

Comment 2

13 years ago
Ive noticed the problem in the 7/13 branch build and today's 7/14 branch

Comment 3

13 years ago
Summarize: adding sites to popup allow list doesn't result in sites able to open
popups (as I understood correctly)
(Reporter)

Comment 4

13 years ago
Thanks i updated the info. Good idea on the summary
Summary: New popup controls that appear as a bar at top of browser below tabs does not function correctly → adding sites to popup allow list doesn't result in sites able to open

Comment 5

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040714
Firefox/0.9.1+
(Reporter)

Comment 6

13 years ago
I'm running the same build as you but it doesn't work. Even after clicking allow
popups from any website it does nothing. The context menus on the popup blocking
alert bar don't work. The popups all remain blocked and I cannot open any
windows into a popup window. Others have confirmed the same happening at
mozillazine?? I fresh installed this build also. Clean profile.

Comment 7

13 years ago
Does this affect all sites or just the one in the URL? Does the first link at
http://www.popuptest.com/ work? Do you get any errors in the Javascript console?
(Reporter)

Comment 8

13 years ago
After reviewing that link and looking back at the GMAIL site.. I have to
conclude that this bug must be tied to javascript because the link you gave me I
was able to use the popup blocker sucessfully and unblock successfully. It must
be isolated to javascript because the contacts link in question on GMAIL uses
javascript. After clicking to allow popups from gmail, I then proceeded to press
the link in question but it no longer functioned. So perhaps this is isolated to
javascript only.

Comment 9

13 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040727
Firefox/0.9.1+

Comment 10

13 years ago
WFM as well using 20040722 Aviary installer build.

Anyone else who is still seeing this with a recent nightly?
(Reporter)

Comment 11

13 years ago
I still see it on GMAIL. The contacts button doesn't work. It now pops up a
message that the popup blocker is blocking the popup. So naturally I click
unblock gmail.google.com then I refresh the page and click again and it still
blocks the popup.. It doesn't work.

Comment 12

13 years ago
Ryan - are you using Tabbrowser Extensions?

I was seeing the same problem - Edit in contacts in GMAIL didn't work.

I disabled TBE and restarted Firefox - boom now it works (20040727 Aviary).

Note - those 'edit' links don't open popups - they open up a little frame thingy
in the same contacts view.
(Reporter)

Comment 13

13 years ago
The only extension I have installed is the web developer toolbar. TBE is not
installed.
(Reporter)

Comment 14

13 years ago
This bug is resolved for me now if anyone else wants to confirmed that it is
fixed as well. (those who also saw problems similar to this) Im using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040811
Firefox/0.9.1+

Comment 15

13 years ago
Since no one else has commented that they still have the problem I'm closing
this bug as WORKSFORME per comment 14, if anyone still sees it please reopen.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.