EM should support remote updating of maxVersion to avoid unnecessary download-install

RESOLVED FIXED in mozilla1.7.4

Status

()

defect
P2
normal
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: bugs, Assigned: bugs)

Tracking

({fixed-aviary1.0})

unspecified
mozilla1.7.4
Points:
---
Bug Flags:
blocking-aviary1.0PR +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Status: NEW → ASSIGNED
Flags: blocking-aviary1.0RC1+
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
Posted patch patchSplinter Review
first, implement this for custom rdf update files
Posted patch patchSplinter Review
hook up to versioncheck service
landed, branch and trunk. documentation updates coming soon. 
landed, branch and trunk. documentation updates coming soon. 
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Why is there a max version check anyway? Crazy. You're going to render
extensions obsolete as developers abandon them. Just check that the install
method is supported and then install. Who cares if your browser is 1.4 and the
extension install method is 0.9, as long as the 0.9 install method is
sufficient? This hack to get deveopers to update their extensions for every
version points out how misguided the check is, no?
(In reply to comment #5)
> Why is there a max version check anyway? Crazy. You're going to render
> extensions obsolete as developers abandon them. Just check that the install
> method is supported and then install. Who cares if your browser is 1.4 and the
> extension install method is 0.9, as long as the 0.9 install method is
> sufficient? This hack to get deveopers to update their extensions for every
> version points out how misguided the check is, no?

How else are you going to allow the extension creators to specify that one
version of their extension is for versions 0.9-0.9.2 and one is for version 1.2-1.3?
Maybe I understand : this is a way to keep extensions developpers in touch for
each release. We can not be sure that an extension will work in a new version.
Extension that aren't updated (at least maxVer) cannot be activated in a public
release. It's a matter of quality and responsibility. In short we are
responsible for our extensions !
>>How else are you going to allow the extension creators to specify that one
version of their extension is for versions 0.9-0.9.2 and one is for version 1.2-1.3?

How about they use one of them whaddayacallit, "version numbers," maybe???

>>this is a way to keep extensions developpers in touch for
each release

I think instead you'll see vast numbers of extensions abandoned because of an
unnecessary hassle. Sounds like a obviously bad system to me.
The max version check is to prevent possibly incompatible extensions from
breaking the browser (yes, it did happen previously).  With that said, please
take this to the forums, as this is not a discussion board.
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.