longislandferry.com - Next button doesn't work on longislandferry.com/bif schedule page

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
15 years ago
4 years ago

People

(Reporter: nstrom, Unassigned)

Tracking

Details

(Whiteboard: HAVEFIX, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

"Next" button doesn't work on linked URL -- clicking it does nothing. I'm
assuming this is a tech evangelism issue (bad Javascript/HTML?), but I didn't
notice anything glaringly wrong from a quick look at the page source.

Reproducible: Always
Steps to Reproduce:
1. Visit https://www.longislandferry.com/bif/schedule.aspx
2. Under "Choose quantity", pick a non-zero number
3. Click the "Next button"

Actual Results:  
Nothing

Expected Results:  
In IE, the Next button brings up the next page
(https://www.longislandferry.com/bif/travel.aspx)

Comment 1

15 years ago
<meta content="Microsoft Visual Studio.NET 7.0" name="GENERATOR">
<meta content="Visual Basic 7.0" name="CODE_LANGUAGE">
<meta content="JavaScript" name="vs_defaultClientScript">

That's the first sign of trouble...

https://www.longislandferry.com/bif/schedule.aspx

The Next button calls to http://www.longislandferry.com/bif/schedule.jsp which
gives me a warning in the JavaScript Console:

function fValidateInput() 
		{ 
			var strAdult; 
			var strChild;
			var strBike;
			var strDeparture; 
			var strOutDate; 
			var strOutTime; 
			var strRoundTrip; 
			var strReturnDeparture; 
			var strReturnDate; 
			var strReturnTime; 
			var strError = ''; 
			var strErrorStdMsg = '';
			var dtOutBoundDateTime= new Date();
			var dtReturnDateTime= new Date();
			 //alert('Hi'); 

			strAdult =
document.frmSchedule.cboAdult.options(document.frmSchedule.cboAdult.selectedIndex).value;


saying that
document.frmSchedule.cboAdult.options is not a function.

Comment 2

15 years ago
The proper use is options[index] I believe. That is:
document.frmSchedule.cboAdult.options[document.frmSchedule.cboAdult.selectedIndex].value;

-> TE
Assignee: general → english-us
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Summary: Next button doesn't work on longislandferry.com/bif schedule page → longislandferry.com - Next button doesn't work on longislandferry.com/bif schedule page
Whiteboard: HAVEFIX
Version: Trunk → unspecified

Comment 3

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.