TB07x Crash when doing multiple advanced address book searches [@ nsAbView::GetCardValue][@ nsAbView::Init]

VERIFIED FIXED in Thunderbird0.8

Status

Thunderbird
Address Book
--
critical
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({crash, topcrash+})

unspecified
Thunderbird0.8
x86
Windows XP
crash, topcrash+
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Assignee)

Description

14 years ago
I'm sure this is a dupe.

1) Bring up the advanced search dialog
2) do a search
3) after it's done, type in some more search criteria and hit search again
4) Crash!
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.8
(Assignee)

Comment 1

14 years ago
Created attachment 153318 [details] [diff] [review]
the fix

the view was getting initialized with null values
(Assignee)

Comment 2

14 years ago
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Severity: normal → critical
Keywords: crash
Summary: crash when doing multiple advanced address book searches → Crash when doing multiple advanced address book searches
*** Bug 253509 has been marked as a duplicate of this bug. ***
This bug isn't fixed. I can reproduce it with Thunderbird version
0.7+ (20040727). I send following talkback id: TB437454H

Patrick can you test a current nightly build if it appears for you under Linux?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

14 years ago
(In reply to comment #4)
> This bug isn't fixed. I can reproduce it with Thunderbird version
> 0.7+ (20040727). I send following talkback id: TB437454H
> 
> Patrick can you test a current nightly build if it appears for you under Linux?

the current nightly build dont works on my machine :-(

./run-mozilla.sh: line 423:  3992 Segmentation fault      "$prog" ${1+"$@"}

i´ll try do compile it perhabs this helps

Updated

14 years ago
Summary: Crash when doing multiple advanced address book searches → Crash when doing multiple advanced address book searches [@nsAbView::Init]

Comment 6

14 years ago
now i have tested it with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-0.7.1/

there is the same drouble.

perhabs my selfcompiled version works. but this will take same hours :)
Patrick, this is the wrong version. You have to test the branch 0.8. Take a look
here to get a current build:
ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-0.8/

Comment 8

14 years ago
Created attachment 154635 [details]
error picture

this version (trunk-0.8) also dosent work on my machine.

if i start tb a dialog opens (with the title: gecko). see atachement
(In reply to comment #8)
> if i start tb a dialog opens (with the title: gecko). see atachement

This is another bug which i don't remember actually. 

Scott, do you have enough informations to fix this bug?

Comment 10

14 years ago
i have now compiled the latest version of mozilla added the fix, but the bug is
also there
The problem for Seamonkey is handled in bug 252759.

Comment 12

14 years ago
compiled seamonkey applied patch and works. 
(Assignee)

Comment 14

14 years ago
Henrik, can you retest on a current nightly? It's possible the fix for Bug
#254199 also addressed the crash you are still seeing.
I tried it several times with version 0.7+ (20040802) and can't reproduce it at
this time. When I noticed this crash I had problems to reproduce it. It seems a
little bit strange. Scott, do you made some changes of this code? Should we mark
this bug as WFM while the crash isn't visible?
(Assignee)

Comment 16

14 years ago
marking fixed for now
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 17

14 years ago
Nominating for aviary1.0PR and +'ing aviary1.0 just too make sure this topcrash
is gone before release.
Flags: blocking-aviary1.0PR?
Flags: blocking-aviary1.0+
Keywords: topcrash+
Summary: Crash when doing multiple advanced address book searches [@nsAbView::Init] → TB07x Crash when doing multiple advanced address book searches [@ nsAbView::GetCardValue][@ nsAbView::Init]

Comment 18

14 years ago
*** Bug 256636 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

14 years ago
FYI, any bug that was fixed with a target milestone of 0.8 means it was fixed
for the branch. The PR1.0 stuff is some firefox tracking info and isn't needed here.
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-

Comment 20

14 years ago
Got it... thanks Scott.

Marking this verified based on Talkback data and the fact that I cannot
reproduce this with the latest TB08 nightly: version 0.7+ (20040823).
Status: RESOLVED → VERIFIED

Updated

14 years ago
Flags: blocking-aviary1.0+
Blocks: 252759
Crash Signature: [@ nsAbView::GetCardValue] [@ nsAbView::Init]
You need to log in before you can comment on or make changes to this bug.