Profile Manager Does Not Work.

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: jliebson, Assigned: mscott)

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040715 Firefox/0.9.1+
Build Identifier: version 0.7+ (20040715)

(Please see extension/theme manager submission from me this date.)

When I encountered the extension/theme manager error, I tried to run
Thunderbird.Exe -ProfileManager, which gives this error:

 XML Parsing Error: undefined entity

 Location: chrome://mozapps/content/profile/profileSelection.xul
 Line Number 38, Column 1:

 <dialog
 ^

I then renamed the Thunderbird profile folder, and ran Thunderbird.Exe. This
created a new profile, but instead of starting Tbird, it sent the computer into
an infinite loop, requiring a reboot.

Reproducible: Always
Steps to Reproduce:
1. See details, above, please.
2.
3.



Expected Results:  
Should have been able to create a new profile and start Thunderbird, so that I
could further test the extension/theme manager error as reported in my other
submission this date.

Comment 1

15 years ago
I also see this on Linux and Windows 2000. It appeared in the Thunderbird 0.8
nightly (version 0.7+) after July 13. It did NOT appear on the July 13 build (0.8).

I was unable to start Thunderbird until I changed profiles.ini to make
StartWithLastProfile=1

Comment 2

15 years ago
I have to suspect the changes by bsmedberg on July 14th, but I can't put my
finger on it.

Comment 3

14 years ago
OK, someone just renamed mozilla/toolkit/locales to mozilla/toolket/locale
(doesn't appear in Changelog). I think this might have something to do with this ;)

Comment 4

14 years ago
At least a fresh 7-14 branch installer on a fresh Win 2003 does it.

Comment 5

14 years ago
This bug was mentioned in response to the MozillaZine formum post: "zip build
07-19-04-0.8 won't run" http://forums.mozillazine.org/viewtopic.php?t=102365

Me: The windows 0.8 branch setup build from 2004-07-19 does not launch at all. I
have to kill the process in win2k task manager. Is that THIS bug?

Comment 6

14 years ago
This was caused by changes to the repackaging script, which doesn't recurse
subdirectories. Should be fixed now: en-US-jar.mn 1.21.6.12 (and I added a
warning about that in the file).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 7

14 years ago
Appears to fixed on 0.8 nightly version 0.7+ (20040722).
vrfy'd fixed on the three main platforms (used -profilemanager) with 200411220x-0.9.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.