clicking "highlight" in the find toolbar does not restart visible timer

RESOLVED FIXED in mozilla1.7.4

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Michael Clackler, Assigned: Michael Clackler)

Tracking

({fixed-aviary1.0})

1.7 Branch
mozilla1.7.4
fixed-aviary1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040714 Firefox/0.9.1+ (MOOX-AV)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040714 Firefox/0.9.1+ (MOOX-AV)

The find toolbar is on a timer that controls how long the toolbar is visible
(approx 5 sec).  Pressing a key or clicking "Find Next" or "Find Previous"
resets this timer since you are actively using the toolbar.  Clicking
"highlight" should also reset the display timer like "find next/previous" since
you are using the toolbar, but the timer is not reset.

Reproducible: Always
Steps to Reproduce:
1.activate the find toolbar
2.wait approx 4 seconds and click "Highlight"
3.

Actual Results:  
The toolbar closes within approx. 1 second

Expected Results:  
The toolbar should have remained visible for approx. 5 seconds after "Highlight"
was clicked before it closed

Comment 1

14 years ago
I can confirm this behavior, OS -> ALL

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040725 Firefox/0.9.1+
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Summary: clicking "highlight" in the find toolbad does not restart visible timer → clicking "highlight" in the find toolbar does not restart visible timer
(Assignee)

Comment 2

14 years ago
Created attachment 154727 [details] [diff] [review]
patch to fix

This patch adds "if (gFindMode != FIND_NORMAL) setFindCloseTimeout();" to the
highlight toolbarbutton oncommand.  

The patch fixes this problem by restarting the find toolbar close timer when
the highlight button is pressed in FAYT mode.

I hope the patch is in the correct format, this is my first.
(Assignee)

Comment 3

14 years ago
Created attachment 154823 [details] [diff] [review]
patch - v2

Here's the patch in a better format.

I had bad line feed charaters in the last patch causing the patch to replace
the complete file.
Attachment #154727 - Attachment is obsolete: true
(Assignee)

Comment 4

14 years ago
Comment on attachment 154823 [details] [diff] [review]
patch - v2

makes highlight button reset close counter
Attachment #154823 - Flags: review?(firefox)
(Assignee)

Comment 5

14 years ago
requesting blocking-aviary1.0PR since patch exists
Flags: blocking-aviary1.0PR?

Updated

14 years ago
Whiteboard: [have patch]

Updated

14 years ago
Attachment #154823 - Flags: review?(firefox) → review+

Comment 6

14 years ago
Steffen, have you got a moment to check this one-liner in?

Comment 7

14 years ago
Checked into branch, with some added whitespace to make it look nicer.
-> mikeclackler@hotmail.com.
Assignee: firefox → mikeclackler
Hardware: PC → All
Target Milestone: --- → Firefox1.0beta

Comment 8

14 years ago
-> fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking-aviary1.0PR?
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Whiteboard: [have patch]
Version: unspecified → 1.0 Branch
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.