Moving bookmarks while Bookmarks Manager is in a sorted view has unexpected results

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: John A. Bilicki III, Assigned: Vladimir Vukicevic (BM, do not Cc or Request))

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When you click and drag a bookmark, IE puts it between the two bookmarks where
you want it.  Firefox does not AND moves other bookmarks for who the hell knows
why?  This applies to both files and folders.

Reproducible: Always
Steps to Reproduce:
1. Umm, bookmark stuff
2. Click, hold mouse button down, move bookmark between any other two bookmarks.
3. Revert to IE and hope that something this simple is actually fixed BEFORE a
final release. >__>

Actual Results:  
I reverted back to IE as my default browser.

Expected Results:  
When you click on a bookmark and drag it between two other items, it should put
the bookmark there without moving any other items.  Very simple, like IE, only
it randomly moves it.  Besides fixing this ADDING A RIGHT CLICK SORT BY NAME
option kinda would help too.

Doesn't crash program/os, crashses sanity.
Way to file a friendly, motivational bug report.

/be
(Reporter)

Comment 2

14 years ago
Between functionalbility and security, there is nothing that takes the crown. 
So my bad for being a bit of a grinch...

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?

Comment 3

13 years ago
Give us legitimate steps to reproduce and renominate.
Flags: blocking-aviary1.0?
(Reporter)

Comment 4

13 years ago
Windows XP with .91.  I am sure this was an issue with prior versions as well.

Click and drag a bookmark in the bookmark manager to a posistion between two
other bookmarks.  It will not be put there.

After a careful study I think it's actually doing things backwards when it puts
items in place.

As for the bookmark manager itself, it seems to have no pattern when you
move/drag items.  In fact moving one item will make an utterly unrelated item
randomly move it seems in the bookmark manager itself.

The behaviors should simply mimic IE's favorites.

Also a sort by name (folders then bookmarks style like IE) should be implemented
in addition.  This would save us from having to manually organize things.
the only bug I see is that there isn't the greatest feedback on where the drop
will happen (which is known and filed).  I can't reproduce this, even using RTL
layout.
(Reporter)

Comment 6

13 years ago
Where the drop will happen is part of the bug.

When you move a file in the manager it DOESNT move in the manager but it does
move in the bookmarks menu.  I do recall seeing some items actually moving but
not in the expected/correct manner.

As far as the menu goes, I think you have to on top of this odd behavior
actually try to organize things backwards?  XP / .91.

Comment 7

13 years ago
Unable to reproduce with the latest branch builds on windows XP.
(In reply to comment #6)
> When you move a file in the manager it DOESNT move in the manager but it does
> move in the bookmarks menu.
Are you using a sorted view in the Bookmarks manager? If so, try View > Unsorted
in the Manager, then try moving the bookmarks.

Wahey I was right!

Steps to reproduce in the 20041007 nightly:
1. In the Bookmarks Manager, switch to a sorted view (e.g. View > Sorted by
Location)
2. Move a bookmark or folder by drag-'n'-dropping (I moved a folder in the
Bookmarks Toolbar so the resulting "actual" order can be seen in the main
Firefox window)

Actual results:
In the Bookmarks Manager: The moved bookmark and its siblings reorder randomly
In the Bookmarks Toolbar: The moved bookmark moves to a random position - I
can't see any pattern relating the movement made in the Manager and the result
in the Toolbar.

Expected results:
I suppose the View could be returned to Unsorted, the bookmarks actually sorted
into the order in which they were displayed, then the requested movement
performed. An easier workaround would be to disable drag-'n'-drop when a sorted
view is used.

This could be easily reproduced by a newbie using a sorted view and results in
obvious weirdness, so I'm requesting blocking-aviary1.0.
Flags: blocking-aviary1.0?
The only viable fix I can see for this, at least at the last minute like this,
is to remove the buggy sorting UI or disable moving or creating bookmarks while
sorted.  Neither is acceptable at this juncture, for what is a relatively minor
issue.

We're way past the "this is kinda bad" phase of nominations.  Given the lack of
overall negative feedback on this issue (other than "View->Sort is seemingly
pointless"), I see no indication that this is more than a mostly isolated edge case.

Not a blocker, this is a "bug" with a simple workaround (revert to the unsorted
view before trying to arrange bookmarks). 

Severity->minor
Severity: major → minor
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Summary: Bookmarks (BAD) Random adjustments → Moving bookmarks while Bookmarks Manager is in a sorted view has unexpected results
I can't find the bug that had the previous discussion of this; however, I'd like
to just remove the View menu entirely from the bookmarks manager, as its only
function seems to be to cause confusion.  You could still sort by clicking the
bookmarks table columns.

Comment 11

13 years ago
This /is/ fairly poor handling. For 1.0, why not a simple:

on (move) {
        if (view_is_sorted) {
                alert('Please change your bookmark view to "unsorted" (in the
                       "View" menu) before attempting to manually arrange them');
                break;
        ...

Beats attempting the move and doing weird stuff to the poor user's bookmarks.
And is a lot more helpful in cases where user doesn't know/has forgotten that
they are in a sorted view.
Assignee: vladimir → vladimir+bm
(Reporter)

Comment 12

13 years ago
I think it was an XML structure issue.  I don't have the original file anymore
but when I looked at it I didn't see anything pretty.  I think if you
destructure theXML in a way you may be able to reproduce it.  The question then
is... does Firefox or prior versions mess up the xml structure in anyway that
could lead to such behavior?
FWIW, this is very confusing UI, and when you run into this problem it isn't at
all obvious how to fix it.
(Reporter)

Comment 14

12 years ago
I do not think this bug is valid anymore...I can move bookmarks around just fine
and I've been using 20050722 as my default build and have been testing the
latest build about once a week.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 15

12 years ago
As there's no definitive fix, WORKSFORME.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.