Livemark box in status bar can be clicked when livemarks not available

VERIFIED FIXED

Status

()

Firefox
General
--
trivial
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: Thomas Rutter, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+

On the status bar, the second box from the right is for livemarks.

When there are livemarks available for the site, an icon appears here.

However, when there are no livemarks available and you hover over the blank area
it will still say "Create Livemark for this page" and when you click it, it pops
up a wierd little menu with nothing in it.

This is trivial.

Reproducible: Always
Steps to Reproduce:
1. Start a new browser session.
2. Go to a page where no livemark icon shows 
3. Hover your mouse over the area where the livemark icon would otherwise be
4. Click
Actual Results:  
Tooltip "Create Livemark for this page"

Clicking brings up empty menu with no items.

Expected Results:  
Tooltip with something like "No livemarks available", or no tooltip.

Clicking should not do anything.

Using default theme.
(Reporter)

Updated

14 years ago
URL: .
Version: unspecified → 1.0 Branch

Comment 1

14 years ago
If this is a considered a bug, it is an underlying XUL bug as far as I can see. 

See http://xulplanet.com/references/elemref/ref_statusbarpanel.html for more
information. Basically you can click on any statusbar item, even when the
underlying images are not shown.

CC'ing Neil on this. Neil is this a bug or is this considered to be intended
behaviour?
URL: .
OS: Windows XP → All
QA Contact: firefox.general → bugzilla
Hardware: PC → All
Version: 1.0 Branch → unspecified

Comment 2

14 years ago
As far as the code goes, it's intended behaviour.

Comment 3

14 years ago
I'm going to confirm this bug, but I don't know if the behavior I'm seeing is
this or not. If it isn't, please inform me, and I'll open a new bug on it.

What I did:

Made a new folder on my BTF called "Livemarks"
Added Cheah Chu Yeow's Redemption in a Blog (http://blog.codefront.net) to the
Livemarks folder (clicked on the lightning bolt)

Followed a Trackback to hao2lians blog (http://hao2lian.blogspot.net)

Attempted to add his blog to Livemarks. I clicked on the spot in the status bar
that said "Create Livemark for this page", though there was no lightning bolt.

When it appeared in my Livemarks folder, the entries were for Redemption in a Blog.

What should happen:
Either 1)With no feeds to add, the area on the status bar should not be clickable
or 2)When attempting to add a site with no feed, an error should be thrown,
rather than adding a feed anyway.

I'm seeing this on Linux, but I don't see how that matters for this particular
issue, as I'm sure its all OS
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Intended behaviour. -> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 5

14 years ago
Simon, should I file a new bug or is my comment (comment #3) intended behavior
also? RFE perhaps? If it is intended behavior, it seems rather wrong (unless I'm
entirely mistaken).
Errm.. not intended behaviour.  It was a byproduct of the status bar boxes not
being hidden any more; patch went in for bug 251062 to fix this.
(Reporter)

Comment 7

14 years ago
(In reply to comment #6)
> Errm.. not intended behaviour.  It was a byproduct of the status bar boxes not
> being hidden any more; patch went in for bug 251062 to fix this.

Bug #251062 states that this was fixed from the 20040717 build.  However, it
hasn't fixed this bug.

I've included an attachment to show the behaviour.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 8

14 years ago
Sorry, my mistake.

This bug is now fixed - I was using incorrect build.  It is fixed nicely in the
latest nightly :)
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → general
You need to log in before you can comment on or make changes to this bug.