<iframe> target to _top loading in iFrame

VERIFIED DUPLICATE of bug 22864

Status

()

Core
Layout: HTML Frames
P3
major
VERIFIED DUPLICATE of bug 22864
18 years ago
18 years ago

People

(Reporter: mrMark, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Link Exchange loads their banner into an <iframe> with the anchor on the graphic
targetting _top.  However, when clicking on the banner, the site loads within
the <iFrame>.

At the given sample URL, the very top banner is a Link Exchange banner.

Comment 1

18 years ago
Reassigning to Eric.
Assignee: karnaze → pollmann
(Assignee)

Comment 2

18 years ago
This works for me in today's build.  I'm attaching a test case.
(Assignee)

Comment 3

18 years ago
Created attachment 4628 [details]
Contents of iframe, link target is _top
(Assignee)

Comment 4

18 years ago
Created attachment 4629 [details]
Test case
(Assignee)

Comment 5

18 years ago
Marking worksforme.  If you are still able to duplicate this bug in a more
recent build (nightly build would be good to test), please indicate the build
you tried with and the URL you were able to duplicate the bug at.  Thanks!
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
Build: 2000012715

Test URL: http://www.linkexchange.com/

Test iFrame: Top banner ad is an iframe with the displayed graphic target="_top" 
clicking on the graphic will load the following page within the iFrame.
Status: RESOLVED → REOPENED
(Assignee)

Comment 7

18 years ago
Ah got it.  Thanks for reopening this as it is a valid issue.  This is actually
already known as bug 22864.  The reason clicking on the ad doesn't update the
entire document is because the ad is actually of this form:

<a href=blah target=blah><img src=blah ismap></a>

(not what is contained inside the <iframe> tag, but the document at the src url)

This is identical to the test case in bug 22864, so I'm marking it a dup.


*** This bug has been marked as a duplicate of 22864 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: WORKSFORME → DUPLICATE

Comment 8

18 years ago
Marking verified dup of 22864.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.