Menu item moves when pressing Esc

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Arpad Biro, Assigned: Pierre Chanial)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; hu-HU; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; hu-HU; rv:1.7) Gecko/20040616

Pressing Esc without releasing the mouse button makes the active menu item move.


Reproducible: Always
Steps to Reproduce:
1. open a submenu in the Bookmarks menu
2. click on a menu item in that submenu, but do not release the mouse button
3. press Esc

Actual Results:  
The menu item moves to another location in the same menu, the parent menu
or some other submenu.

Comment 1

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616

Bookmarks->Mozilla Project->mozilla.org->Feedback
When I click on Feedback, hold the mouse, 
press ESC: Feedback closes, Mozilla Project->mozilla.org still selected
press ESC: mozilla.org closes, Mozilla Project still selected
press ESC: Bookmarks Submenu closes

Seems to be correct behaviour, what do you expect?
(Reporter)

Comment 2

14 years ago
The menu does close, but the menu item on which the mouse button was pressed
(without releasing it) moves elsewhere. For me, "Feedback" moves to the bottom
of the "Webtools" menu or to the "Mozilla Project" menu or to the Personal
Toolbar after pressing Esc (and then releasing the mouse button).

The same happens when using the Bookmarks menu on the Personal Toolbar.
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 4

13 years ago
I cannot reproduce it with Firefox 20050828 on SUSE, so this could have been fixed.

Comment 5

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050929
Firefox/1.6a1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.