If I log in to the content management system 'Reddot' using an administrator account, i get logged in as an author.

RESOLVED EXPIRED

Status

()

Firefox
General
--
major
RESOLVED EXPIRED
14 years ago
12 years ago

People

(Reporter: Christoph Eschweiler, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Doing the same thing in IE (same account) it works fine and i can access the
restricted modules.
I tried it on different machines (XP, Win2000, Win2000 Server) but it never
worked. I thought that couldn't be a browser mistake because the login is on the
server side but as soon as realized that IE doesn't have this problems, i'm
quite sure that it _is_ a browser bug.

I'm sorry for not being able to give you a testing url because I'm talking about
my companies software.

Reproducible: Always
Steps to Reproduce:
1. Calling Reddot Login Page
2. Entering administrator's login datas
3. Hitting submit button

Actual Results:  
I'm getting redirected to the main menu but as soon as i select a project,
I'm getting redirected to the "Smart Edit" mode with no access to "Smart Tree"
mode (only admins have access to the Tree mode) (Account information says: "Your
are logged in with username: admin [administrator account].
Your current rights: author)

Expected Results:  
Should let me choose between Tree or Edit mode after selecting a project and
give me a link to access tree mode and display the correct rights of the admin
account.

I tried it with some extensions (one machine) and without any extensions (clean,
first-time installation) on another machine using different OS (see above)
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.