Closed Bug 251759 Opened 19 years ago Closed 18 years ago

Thunderbird process remain active after closing

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 246909

People

(Reporter: magnero, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7) Gecko/20040626 Firefox/0.9.1

When I close Thunderbird, it remain in task manager as process. So I can't open
another istance of it, I have to terminate it manually from task manager and
then restart it.

Reproducible: Sometimes
Steps to Reproduce:
1. Open Thunderbird
2. Close Thunderbird
Actual Results:  
Thunderbird is still listed as process in task manager.

Expected Results:  
Thunderbird should be closed!
I was going to file a similar bug but I think it might be related to this one.

I can't replicate this on my own machine, but my parents' machine is slower and
that might matter. Basically, on theirs, if anyone opens the profile manager and
then closes, and then re-opens the profile manager again quick enough, it ends
up with two thunderbird.exe's floating about in memory. At this point you must
use the taskmanager to kill both before trying to fire it up again or it will
just park that new instance in limbo as well :P

If you wait a moment after closing the profile manager, and THEN run it again,
there's no problem. At least on my folks' computer, the crux seems to be that
thunderbird (i) takes a little too long to remove itself from memory after it's
shutdown and (ii) does NOT cooperate well if it loads while another instance of
itself is running.
This is very similar to bug #246909

Until the various reasons for Thunderbird hanging around in the background are
discovered and fixed, a workaround would be to display a window with a "KILL"
button on it if all other normal windows are closed, but the Thunderbird process
is still running.
   This way even inexperienced users will quickly see that Thunderbird is still
running and that is the reason why they cannot open a new instance.  The KILL
button will supply an easy way to "end process".
A temporary solution under Windows may be:

Download the freeware program Pskill.

then run thunderbird from a batch file like this:

pskill thunderbird
pskill thunde~1.exe
cd "C:\Program Files\Mozilla Thunderbird"
start thunderbird
exit

and set "Run minimized" in the shortcut of batch file.

I am experiencing a similar problem.  Sometimes (~30%), Thunderbird remains
running if I choose "exit" from the "File" menu.  All windows close and the
application seems to go away.  It remains in the Task Manager.  If I try to
launch Thunderbird nothing appears to happen (I might be asked to select a
profile).  Multiple thunderbird.exe's appear in the Task Manager.  Sometimes
killing 1 kills them all.  Sometimes I have to kill each individually.  It
probably depends on which I pick to kill.

I experience this with released versions 0.6, 0.7, 0.73, and 0.8.  I run 0.5
with no problems.

It feels like this issue may be related to IE.  I sometimes find IE hanging
at the same time, although I usually do not observe this correlation.

I also reported this under bug 246909.
I have now experience this problem with 0.5.

It coincided with my having an Internet Explorer window open that was wedged.

The Thunderbird process would not die.

When I killed Internet Explorer, Thunderbird died.

I don't know why this occurs more frequently with 0.6, 0.7, 0.73, and 0.8.  I 
don't know if it was something about Thunderbird that caused IE to get 
wedged.  Killing Thunderbird did not unblock (or kill) the IE process.
My report regarding similar behavior on 0.5 may be misleading.

With 0.6, 0.7, 0.73, and 0.8, I experience this problem several to many times 
a day, making Thunderbird almost unusable.

With 0.5, the problem has come up only once in the last month.  This might 
have been a different problem.

I see that this Bug is still marked Unconfirmed.  I am willing to provide more 
information to get it addressed.
I have upgraded to 0.9.

Occurrences of this bug seem to be somewhat diminished.  It does seem to crop 
up about once or twice a day, still.
I am running 1.0 (released dec-07-2004), and see this every time.

Everybody seems to be cross-posting comments to bug 246909; should these be
marked as duplicates? I'm going to pop over there and post more information.
I have the same problem when I closed Thunderbird it runing again. Dont't help
terminated it in task menager. I try it i Thunderbird 0.6.0+ and 1.0.0 
Please do somting with that problem
sory for English
(In reply to comment #8)
> Everybody seems to be cross-posting comments to bug 246909; should these be
> marked as duplicates?
Yes.
Closing as DUP of bug 246909.

*** This bug has been marked as a duplicate of 246909 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.