Home button and Go > Home don't follow preference

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
not sure if this has the same cause as bug 178168, but that one is old and
hasn't had activity for over a year.

found using 2004-07-15-09-0.9 (branch) on Mac OS X while running these tests:

http://testrunner.mozilla.org/test.cgi#735 - setting homepage to tabs
http://testrunner.mozilla.org/test.cgi#736 - setting homepave via bookmark

also fails for this simpler test:

1. open Prefs > General > Home Page

2. enter a simple URI, like http://google.com

3. click OK to save and dismiss prefs (quitting and restarting optional, bug
still occurs).

4. click Home button in nav toolbar or select Go > Home from menubar.

expected: http://google.com should load.

actual results: http://www.mozilla.org/products/firefox/ loads instead.

note: this does work if I open a new window (cmd+N or File > New Window).

Comment 1

14 years ago
WFM on trunk and branch
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.