[WinNT] Compile error in /mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(783)

RESOLVED INVALID

Status

()

--
blocker
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: ali, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Using Windows NT4 SP6a / Visual C++ 6.0 SP5 I get the following error when 
compiling Firefox:

nsIEProfileMigrator.cpp
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(122) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(141) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(156) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(173) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(195) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(216) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(231) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(248) : warni
ng C4390: ';' : empty controlled statement found; is this the intent?
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(783) : error
 C2664: 'ReadItem' : cannot convert parameter 6 from 'unsigned char ** ' to 'cha
r ** '
        Types pointed to are unrelated; conversion requires reinterpret_cast, C-
style cast or function-style cast
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(860) : error
 C2664: 'ReadItem' : cannot convert parameter 6 from 'unsigned char ** ' to 'cha
r ** '
        Types pointed to are unrelated; conversion requires reinterpret_cast, C-
style cast or function-style cast
c:/mozilla/browser/components/migration/src/nsIEProfileMigrator.cpp(986) : error
 C2664: 'ReadItem' : cannot convert parameter 6 from 'unsigned char ** ' to 'cha
r ** '
        Types pointed to are unrelated; conversion requires reinterpret_cast, C-
style cast or function-style cast
make[6]: *** [nsIEProfileMigrator.obj] Error 2

My mozconfig is as follows:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../mozobjdir

. $topsrcdir/browser/config/mozconfig
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --enable-optimize
ac_add_options --enable-static
ac_add_options --disable-shared

CVS Checkout Time: checkout start: Fri Jul 16 12:28:20 PDT 2004
Branch: AVIARY_1_0_20040515_BRANCH
(Reporter)

Updated

14 years ago
Assignee: bryner → bugs
Component: Build Config → Migration
QA Contact: asa → firefox.migration
(Reporter)

Comment 1

14 years ago
Marking this as invalid, since obviously migration is now being built correctly!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.