Form Manager should be case-sensitive

RESOLVED WORKSFORME

Status

()

Toolkit
Form Manager
RESOLVED WORKSFORME
14 years ago
6 years ago

People

(Reporter: jay, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
This failed our basic Firefox functionality test:
http://testrunner.mozilla.org/test.cgi?run_id=243#819

I cannot save multiple entries using upper AND lower case for any given item.  

Steps:
1. http://www.mozilla.org/wallet/samples/sample2.html
2. Fill in my first name in lowercase (jay) and submit.
3. Fill in my first name in uppercase (Jay) and submit.
4. Focus on the first name field and use the down arrow to open the drop-down list.

Actual result:
Only "jay" is displayed

Expected result:
Both "jay" and "Jay" should be in the drop-down list for me to select

Not a huge problem in most cases.  For those cases where someone needs to fill
in a form and the site/web app requires case-sensitive names, this bug will be
annoying if the user doesn't save the right info the first time.  But most forms
won't care about case-sensitivity.

The real problem is if the user has Password manager disabled and the Form
manager starts to store usernames for various sites...

If we decide not to deal with the case-sensitivity, perhaps the Form manager
should not store any username/login related info and just have the Password
manager remember only the username (if the user chooses not to save the password).

Comment 1

12 years ago
bug 305809 implies that this bug has been fixed.

Comment 2

12 years ago
*** Bug 305809 has been marked as a duplicate of this bug. ***
I suspect it was an accident, but nsStorageFormHistory.cpp, the SQLite version that the trunk is now using, does case-sensitive comparison in EntryExists, so this is certainly now WFM for the trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.