"Message exceeds global size limit of server" when sending - MailEnable server

RESOLVED WORKSFORME

Status

MailNews Core
Networking
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Shane Garven, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Trying to send a small 2 or 3 line plain text email using my correct and working
mail server settings (both POP and SMTP), I was returned an error dialog from
Thunderbird with the following message;

"The size of the message you are trying to send exceeds the global size limit of
the server. The message was not send, try to reduce the message size and try
again. The server responded: Message size exceeds fixed maximum message size."

This occurs while sending using a MailEnable mail server. By default the global
size limit on the SMTP agent in MailEnable is set to 0 (zero) which is the
setting required for unlimited size messages to be sent. Fortunately, I had
control of this server and added a large size limit to the MailEnable mail
server (replacing the default 0 (zero) which should be unlimited) and
Thunderbird then sent the message ok.

Reproducible: Always
Steps to Reproduce:
1. Must be sending via a MailEnable mail server (only tested with Standard
Edition) - with the SMTP agent outgoing message size set to "default" size of 0
(zero) - which indicates it should allow unlimited size messages to be sent
through it.
2. Compose new message in Thunderbird of minimal size - I guess any size will do.
3. Attempt to send the message.

Actual Results:  
An error dialog was displayed to me - a well handled error - and I was unable to
send the message. 

This error is not returned using either Outlook 2003 or Outlook Express 6.xxx. I
guess Thunderbird is returned the 0 (zero) from the mail server (it's default
mail sending size setting - which indicates unlimited size in MailEnable mail
server) and then sees that the message size is greater than zero and handles the
error.

Expected Results:  
Should have allowed me to send the message knowing that zero is indicative of
unlimited SMTP message size allowed to be sent via MailEnable.

If this had been a mail server I didn't control - which is a majority of cases
it would be - then there is no simple work-around unless you are good friends
with the SysAdmin at the ISP or similar.

Because I wanted to see if anything was wrong a my end (ie; mail server) I
remoted into the server and checked a few things. Most people won't have that
ability.
(Reporter)

Comment 1

14 years ago
Created attachment 153506 [details]
Thunderbird error dialog - as described in bug submission

Comment 2

14 years ago
Shane, I'm the person who implemented the SIZE feature. And I took care for the
case where the parameter for SIZE in EHLO response is 0, in this case the
"limit" is ignored.

The alert you see is thrown if the server sends code 552 in response to MAIL
FROM or RCPT TO command. And I can't see why this is our problem.

Unfortunately I only have Win98 available and can't test MailEnable. So it would
be nice if you could attach a communications log here (please use the create
attachment function above). See
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp how to
create one.

Comment 3

13 years ago
It happens with zip files but even larger tif files are sent without problem.
Obviously a bug.

Comment 4

13 years ago
(In reply to comment #3)
> It happens with zip files but even larger tif files are sent without problem.
> Obviously a bug.

Maybe, but where - Server or client?
If you again get that message (unnecessarily in your opinion), please set up the
system to create a log as mentioned in comment #2 and try it again.

Comment 5

13 years ago
*** Bug 308325 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
I guess this is a core bug - I will reassign.
Component: General → MailNews: Networking
Product: Thunderbird → Core
Summary: error - message exceeds global size limit of server → "Message exceeds global size limit of server" when sending - MailEnable server
Version: unspecified → Trunk

Comment 7

13 years ago
Does anyone have access to a MailEnable server to test this and get some logs?

Comment 8

13 years ago
Ok, after all the requests and being able to since I now run W2K, I installed
MailEnable and tried to send a big mail.
With standard values TB failed and threw "The size of the message you are trying
to send exceeds the global size limit (5120000 bytes) of the server." which is
right since that's the standard limit advertised in the EHLO header by
  250-SIZE 5120000
After setting the "Advertised Maximum Message Size" in the SMTP options to 0 it
advertises
  250-SIZE 0
and TB has no problem sendig a mail with over 6 megabytes in size.

So I'm sorry that I can't find anything other than what I expected and how it
should be. I can't do anything else that again ask for a TB-log from those users
having problems. It's simple to create, a batch file containing

set NSPR_LOG_MODULES=SMTP:5
set NSPR_LOG_FILE=D:\bug251686.log
start E:\thunderbird\thunderbird.exe

did it for me (you should adjust your pathes).

Comment 9

13 years ago
(In reply to comment #8)
> 
> So I'm sorry that I can't find anything other than what I expected and how it
> should be. I can't do anything else that again ask for a TB-log from those users
> having problems. It's simple to create, a batch file containing

So invalid?
WFM per comment 8.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.