Build fails if gnome libs not present even though gnome support was disabled

RESOLVED DUPLICATE of bug 251703

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 251703
14 years ago
14 years ago

People

(Reporter: Stephan Jaensch, Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
I just tried building an updated firefox RPM, but the build fails. Never had
problems before (last build was June 4th).

Trunk build fails with the following error message. Please note that I have
specifically disabled gnomevfs and gnomeui (configure information and output
provided at the end):

gmake[2]: Entering directory `/home/sj/developing/mozilla/toolkit/components/gnome'
nsGConfService.cpp
c++ -o nsGConfService.o -c -DOSTYPE=\"Linux2.6.5-7\" -DOSARCH=\"Linux\"
-DHAVE_DEPENDENT_LIBS  -I../../../dist/include/xpcom
-I../../../dist/include/string -I../../../dist/include/necko
-I../../../dist/include/mozgnome -I../../../dist/include
-I/home/sj/developing/mozilla/dist/include/nspr  -I/usr/include -I/usr/include
-I/usr/include -I. -I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -pedantic -O2 -g -march=i686 -mcpu=i686 -fshort-wchar -pthread
-pipe  -DNDEBUG -DTRIMMED -ffunction-sections -O2 -g -march=i686 -mcpu=i686    
 -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h
-Wp,-MD,.deps/nsGConfService.pp nsGConfService.cpp
In file included from nsGConfService.cpp:39:
nsGConfService.h:43:32: gconf/gconf-client.h: Datei oder Verzeichnis nicht gefunden
nsGConfService.cpp:43:32: gconf/gconf-client.h: Datei oder Verzeichnis nicht
gefunden
gmake[2]: *** [nsGConfService.o] Fehler 1
gmake[2]: Leaving directory `/home/sj/developing/mozilla/toolkit/components/gnome'
gmake[1]: *** [tier_9] Fehler 2
gmake[1]: Leaving directory `/home/sj/developing/mozilla'


Configure command (relevant output below):

export MOZ_PHOENIX=1
export MOZ_INTERNAL_LIBART_LGPL=1
export MOZILLA_OFFICIAL=1
export BUILD_OFFICIAL=1
export CFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$CFLAGS"

./configure \
      --with-system-jpeg=/usr \
      --with-system-zlib=/usr \
      --with-system-png=/usr \
      --with-pthreads \
      --enable-default-toolkit=gtk2 \
      --enable-extensions=default,-inspector,-venkman \
      --enable-crypto \
      --enable-xinerama \
      --enable-plaintext-editor-only \
      --enable-xft \
      --enable-freetype2 \
      --disable-gnomevfs \
      --disable-gnomeui \
      --disable-mailnews \
      --disable-composer \
      --disable-calendar \
      --disable-ldap \
      --disable-tests \
      --disable-debug \
      --enable-strip \
      --enable-strip-libs \
      --enable-reorder \
      --enable-optimize="$CFLAGS" \
      --with-default-mozilla-five-home=%{progdir} \
      --disable-installer


Relevant configure output:

checking for gconf-2.0 >= 1.2.1... Package gconf-2.0 was not found in the
pkg-config search path.
Perhaps you should add the directory containing `gconf-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gconf-2.0' found
checking for libgnome-2.0 >= 2.0... Package libgnome-2.0 was not found in the
pkg-config search path.
Perhaps you should add the directory containing `libgnome-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnome-2.0' found
configure: warning: Cannot build gnomevfs without required libraries. Removing
gnomevfs from MOZ_EXTENSIONS.

*** This bug has been marked as a duplicate of 251703 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.