Java system property user.home does not return user directory

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: dalpian, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

When we do a call in the Java Plugin under Firefox to the system property 
user.home (System.getProperty("user.home")), it returns the Firefox 
installation directory, and not the user home in Windows 2000!

The problem is that the installation directory normally is not writable to a 
not privileged user. The correct directory should be the user directory in 
windows (normally c:\documentes and settings\<username>).

Reproducible: Always
Steps to Reproduce:
1. Create a java applet
2. Return the system property "user.home"
3. If it is the case of a signed applet and you try to write to that directory, 
you will run into trouble.

Actual Results:  
You don't have permission to write to the user.home directory.

Expected Results:  
You should have permission, with user.home returning the user directory 
(c:\documents and settings\<username>)
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.