impossible to check the "always perform this action..." option on certain file types download

RESOLVED INVALID

Status

Core Graveyard
File Handling
RESOLVED INVALID
14 years ago
2 years ago

People

(Reporter: tripleshift, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

in this forum(phpbb) page: http://forum.psd.it/viewtopic.php?t=11590 , if you
try to open the image clicking on the download link below the clip icon, you got
the dialog window with question about how to handle the file.
for some type of extensions (jpg, gif etc.) the "always perform this action ..."
option is grayed and impossible to check. other extensions work well!
I first noticed this bug with the 1.7 alpha, and since now I'm still dealing
with it.

I hope that was clear.

bye

...


Reproducible: Always
Steps to Reproduce:
1) go to that url: http://forum.psd.it/viewtopic.php?t=11590
2) click on the download link below the clip icon on the first post

when the dialog appears you can easily see the grayed out option.
Actual Results:  
the dialog appears and the "always perform this action ..." option is grayed out.

Expected Results:  
simply allow thw user to check the "always perform this action ..." option!

this problem has come together with the 1.7alpha, 'till 1.6 everything was fine.
> 'till 1.6 everything was fine.

not really, since that checkbox was ignored. because of that, to avoid showing
UI that doesn't work anyway, bug 193698 greyed out the checkbox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.