Pasting a paragraph leaves cursor on 2nd to last line, not the end of the pasted text

RESOLVED DUPLICATE of bug 243643

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 243643
13 years ago
13 years ago

People

(Reporter: Airin, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

OK, here is an example. I am on several humor lists, below is one e-mail I
received. I copied the text in ThunderBird, and pasted into a new Compose window
(to send it to some friends).
-------------------------------
GCF: Overboard!

On a U.S. cruiser the officer of the deck asked the starboard lookout, 
"What would you do if a sailor was washed overboard?"

"I'd yell MAN OVERBOARD!" answered the lookout snappily.

"Good," said the officer. "Now what would you do if an officer fell 
overboard?"

The lookout asked, "Which one, sir?"
-------------------------------
After pasting it into the Compose window, my cursor is located at the end of the
line <overboard?">. I usually forward many things at once to friends, and hit
enter half a dozen times in between to seperate them. If I do this right after
pasting, then the last line of the joke gets moved down. 

If I then Copy this text from the Compose window, and create a new Compose, it
works as expected. It seems to work fine if copied from a textbox (as I enter
this bug report) or a compose window, but not if I copy directly from an e-mail
in Thunderbird. It also seems to work fine when copying from Firefox (not fully
tested). 

Reproducible: Always
Steps to Reproduce:
1. Copy many lines of text in Thunderbird (at least 8-10, haven't tested the
number needed)
2. Paste into new Compose window (or existing Compose window)
3. Cursor will not be at end of text (usually, some shorter paragraphs seem to
work, some do not). 

Actual Results:  
Text cursor not at expect spot to continue typing, requires you to reposition it
so you don't type into the copied text

Expected Results:  
Cursor should be at bottom of copied text.

Comment 1

13 years ago
Reporter (Airin): is this bug still a problem for you with TB 1.0?  If not, 
please mark the bug   Resolved | WorksForMe.

If is still a problem: is the message you're copying from an HTML or plain text 
message?  Are you pasting into an HTML or plain text compose window?
(Reporter)

Comment 2

13 years ago
Aloha, I am using Thunderbird 1.0 (20041206). The bug still happens. I copied 3
paragraphs of text, a total of 10 lines from a text e-mail (Content-Type:
text/plain). After I pasted it into my new Compose window (no HTML Formatting
set, just pasted paragraphs from plain text e-mails), the text-input-focus was
at the end of the 9th line, with the 10th line of text below it. If I hit enter
several times to seperate pasted items from each other, the 10th line of text is
seperated from the 9th. 

Suggested result when pasting text: Have input-focus appear at the end of pasted
text, instead of the line before then end of the pasted text. 
Version: unspecified → 1.0

Comment 3

13 years ago
Getting back to this bug: Airin, do you have any extensions installed which 
could cause this problem?  If you start TB in Safe Mode, does the problem still 
occur?
(Reporter)

Comment 4

13 years ago
Aloha, I have disabled all Thunderbird extensions now. Same bug appears (after
pasting, cursor location is at end of line on 2nd to last line of text). Text I
copied (half a page or so from another e-mail I received in thunderbird) has a
content type of text/plain. Also happens if I click Edit --> Paste as Quotation.
Does NOT happen (works as expected) if I click Edit --> Paste Without Formatting
(also shows a different font then). Starting thunderbird in SafeMode has exact
same results.

Comment 5

13 years ago
(In reply to comment #4)
> Does NOT happen (works as expected) if I click Edit --> Paste Without
> Formatting (also shows a different font then). 

A different font?  When I paste plain text, I get the same font for generic 
Paste and for Paste Without Formatting.  What are your settings for the HTML 
composition font (face and size), and which font is used for each of the two 
paste cases?

Comment 6

13 years ago
After email from reporter, I see the problem, and found a dupe.

*** This bug has been marked as a duplicate of 243643 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.