If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Warning: ATSUMeasureText has been deprecated. Use ATSUGetUnjustifiedBounds

RESOLVED DUPLICATE of bug 161332

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED DUPLICATE of bug 161332
13 years ago
13 years ago

People

(Reporter: Krishna Sethuraman, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a3) Gecko/20040717 Firefox/0.9.1+
Build Identifier: Thunderbird version 0.6+ (20040717)

I'm getting this message in my syslog -- see also bug 161332 .  I'm running into
this under Panther (MacOSX 10.3.4)

Reproducible: Always
Steps to Reproduce:
1. Run Thunderbird nightly under MacOSX 10.3.4
2. Watch your syslog
3.

Actual Results:  
Over time the following showed up in my syslog:


Jul 17 21:04:31 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
/tmp/Thunderbird.app/Contents/MacOS/thunderbird-bin could not be launched prebound.
Jul 17 21:04:48 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
/tmp/Thunderbird.app/Contents/MacOS/libnspr4.dylib must be slid, but
fix_prebinding could not find a good place to relocate it.
Jul 17 21:04:48 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
/tmp/Thunderbird.app/Contents/MacOS/thunderbird-bin appears to have no
prebinding problems.
Jul 17 21:04:48 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
2004-07-17 21:04:48 -0700: prebinding for thunderbird-bin done.
Jul 17 21:06:46 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
/tmp/Thunderbird.app/Contents/MacOS/thunderbird-bin could not be launched prebound.
Jul 17 21:07:07 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
/tmp/Thunderbird.app/Contents/MacOS/libnspr4.dylib must be slid, but
fix_prebinding could not find a good place to relocate it.
Jul 17 21:07:07 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
/tmp/Thunderbird.app/Contents/MacOS/thunderbird-bin appears to have no
prebinding problems.
Jul 17 21:07:07 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
2004-07-17 21:07:07 -0700: prebinding for thunderbird-bin done.
Jul 17 21:09:07 Krishna-Sethuramans-Computer /usr/libexec/fix_prebinding:
fix_prebinding quitting for now.
Jul 17 21:14:41 Krishna-Sethuramans-Computer
/private/tmp/Thunderbird.app/Contents/MacOS/thunderbird-bin: *** Warning:
ATSUMeasureText has been deprecated.  Use ATSUGetUnjustifiedBounds instead. ***


Expected Results:  
Probably be using the function in question, but I'm not really that familiar
with the Mac API.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 161332 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.