Firefox crash by printing http://www.linux-praxis.de/lpic1/lpi101/1.102.2.html [@ lexpsnt3.dll - CompositeBitsInMemory ]

RESOLVED DUPLICATE of bug 317420

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 317420
14 years ago
7 years ago

People

(Reporter: Richard Karsch, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

Firefox crash by printing http://www.linux-praxis.de/lpic1/lpi101/1.102.2.html

Reproducible: Always
Steps to Reproduce:
1. go to http://www.linux-praxis.de/lpic1/lpi101/1.102.2.html
2. File -> Print .. 

Actual Results:  
Crash

Comment 1

14 years ago
Richard: Could you provide TalkBack incident ID?
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Richard: Could you provide TalkBack incident ID?

Adam: How can I get the ID? I sent a report with the Quality Feedback Agent but 
I haven't seen any ID. However, I wrote the Bug ID in the QFA description.

Regards Richard

Comment 3

14 years ago
Richard: Thanx, I found your report, stacktrace below.

If you wanna find TalkBack incident ID, go yo you Firefox directory, to
subdirectory components. There are talkback.exe, run it and you will get id list
of sent incidents. You should see TB357542 there.

TB357542:
lexpsnt3.dll + 0x87b8 (0x035f87b8)
lexpsnt3.dll + 0x899a (0x035f899a)
lexpsnt3.dll + 0x8a8a (0x035f8a8a)
GDI32.DLL + 0x2d454 (0x77f6d454)
USER32.DLL + 0x7798 (0x77e07798)
ntdll.dll + 0x1ff57 (0x7789ff57)
CompositeBitsInMemory
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/gfx/src/windows/nsImageWin.cpp,
line 2035]
nsImageWin::Draw
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/gfx/src/windows/nsImageWin.cpp,
line 570]
nsRenderingContextImpl::DrawScaledImage
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/gfx/src/shared/nsRenderingContextImpl.cpp,
line 880]
nsImageFrame::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsImageFrame.cpp,
line 1305]
nsContainerFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 306]
nsBlockFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/table/src/../../base/src\nsBlockFrame.h,
line 244]
nsBlockFrame::PaintChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5467]
nsHTMLContainerFrame::PaintDecorationsAndChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp,
line 141]
nsBlockFrame::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5292]
nsContainerFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 306]
nsBlockFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/table/src/../../base/src\nsBlockFrame.h,
line 244]
nsBlockFrame::PaintChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5446]
nsHTMLContainerFrame::PaintDecorationsAndChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp,
line 141]
nsBlockFrame::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5292]
nsContainerFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 306]
nsBlockFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/table/src/../../base/src\nsBlockFrame.h,
line 244]
nsBlockFrame::PaintChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5467]
nsHTMLContainerFrame::PaintDecorationsAndChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsHTMLContainerFrame.cpp,
line 141]
nsBlockFrame::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 5292]
nsContainerFrame::PaintChild
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 306]
nsContainerFrame::PaintChildren
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 230]
nsContainerFrame::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 211]
nsPageContentFrame::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPageContentFrame.cpp,
line 213]
PresShell::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5567]
nsView::Paint
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp,
line 264]
nsViewManager::RenderDisplayListElement
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1429]
nsViewManager::RenderViews
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 1347]
nsViewManager::Display
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 3248]
nsSimplePageSequenceFrame::PrintNextPage
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsSimplePageSequence.cpp,
line 901]
nsPrintEngine::PrintPage
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintEngine.cpp,
line 3578]
nsPagePrintTimer::Notify
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/base/src/nsPagePrintTimer.cpp,
line 92]
nsTimerImpl::Fire
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 395]
nsAppShellService::Run
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
main
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
KERNEL32.DLL + 0x11af6 (0x77e81af6)
Summary: Firefox crash by printing http://www.linux-praxis.de/lpic1/lpi101/1.102.2.html → Firefox crash by printing http://www.linux-praxis.de/lpic1/lpi101/1.102.2.html [@ lexpsnt3.dll - CompositeBitsInMemory ]

Comment 4

14 years ago
Cannot reproduce on Firefox 0.10
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040926 Firefox/0.10
Windows 98 SE

Comment 5

14 years ago
WORKSFORME

Cannot reproduce the crash on Windows XP SP2.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040928
Firefox/0.9.1+

Comment 6

14 years ago
Reporter: Could you please download a recent nightly build from
<http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-0.9/>, and then
let us know if you still see this problem?  Thanks.

Comment 7

14 years ago
I printed 4 pages of the document found at the provided URL without any problem,
no crash.
Firefox 0.9.1+ rv: 1.8a4 build 20040928 under XP Pro SP2 with a old inkjet Canon
printer here.

WORKSFORME

Comment 8

14 years ago
No response from reporter, and this may be a Lexmark driver issue anyway -> WFM.

Please reopen if you still reproduce with the latest Firefox release and printer
drivers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

14 years ago
Firefox 1.0PR still crashed if I try to print that page. I will send you a new 
Quality Feedback Agent Report.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

14 years ago
Richard, is the problem still happening with the latest Firefox build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
If so, can you provide a talkback incident id? I will resolve this bug as WFM
unless I hear from you on this.

Comment 11

14 years ago
Richard, if the problem occurs with the latest Firefox build, make sure you have
the latest updated lexmark printer driver for your system:

Start/Settings/Control Panel/Printers and Faxes/Select your
printer/Right-click/Properties/Advanced tab/New driver button/Printer Driver
Wizard will make the best selection for you and will verify if there is a more
recent one available.

Or you may go to windows update site.

Resolving as WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 12

13 years ago
erm, this bug doesn't work for you and you had no business squishing a core bug in the firefox product. if you don't like the bug then be a good qa and triage it to the *right* product.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 13

13 years ago

*** This bug has been marked as a duplicate of 317420 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ lexpsnt3.dll - CompositeBitsInMemory ]
You need to log in before you can comment on or make changes to this bug.