Invalid or missing favicon.ico not being saved for HTTPS pages

VERIFIED WORKSFORME

Status

()

Firefox
Bookmarks & History
VERIFIED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Thomas Rutter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040718 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040718 Firefox/0.9.1+

This seems related to the recent bugfixes for favicons and bookmarks.  I have a
particular bookmark on the Bookmarks toolbar which has the incorrect favicon and
has had since before I upgraded to this version of Firefox.

When I go to the page again, Firefox sees that the new favicon for the page is
invalid and removes it.  However, it does not replace it with the generic "Page"
icon.  It just leaves a gap where the icon once was.

In addition, if I restart the browser, the incorrect icon will have reappeared.

Reproducible: Always
Steps to Reproduce:
1. Bookmark a page which has a valid favicon.ico
2. Change the site so its favicon.ico is invalid
3. Revisit the site

Actual Results:  
- Icon next to bookmark disappears and leaves a blank space.
- Reloading the browser causes the old, now invalid, bookmark to reappear.

Expected Results:  
- Bookmark should show generic "Page" icon.
- Should "forget" the old icon which is invalid.

Hard to reproduce because the reproduce steps I gave involve actually making
changes to the website and reloading Firefox.

Comment 1

14 years ago
Confirming with two pages that seem to have invalid favicons currently:
http://www.weather.com/
http://us.codejunkies.com/

in both cases favicon.ico exists but seems to be corrupt.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Note that this also affects the location bar: the normal page icon is missing
there also when the favicon.ico is corrupt.
(Reporter)

Comment 3

14 years ago
Here's an example of the bug I was referring to:

https://select.worldpay.com/wcc/admin

A bookmark of this shows no icon.

Now that I think of it, I can't be sure whether this has anything to do with the
https protocol.

Updated

14 years ago
Assignee: firefox → vladimir
Component: General → Bookmarks
QA Contact: firefox.general → mconnor
(In reply to comment #1)
> Confirming with two pages that seem to have invalid favicons currently:
> http://www.weather.com/

www.weather.com has a 1x1 transparent image as its favicon.ico.

> http://us.codejunkies.com/

codejunkies has a 32x32 transparent image as its favicon.ico.

Nothing I can do about those two cases. :)

Comment 5

14 years ago
That would explain why IE shows them as garbage ... IE can't handle transparancies.
(Reporter)

Comment 6

14 years ago
(In reply to comment #2)
> Note that this also affects the location bar: the normal page icon is missing
> there also when the favicon.ico is corrupt.

Actually the bug does not affect the location bar - only the icon shown in
bookmarks.  The reason the icon didn't show in the location bar for those pages
is that the icon is a transparent image.

Try to reproduce the problem with the URL I gave and you'll see that the "page"
icon shows in the location bar while you're viewing it, but if you add it as a
bookmark now and then visit the page you will see the bug.

Comment 7

14 years ago
The favicon of bitfluxeditor.org located on http://bitfluxeditor.org/favicon.ico 
is invalid.
The bookmark has no bookmark icon after accessing the page and stored the 
favicon info into bookmark.

Another case:
The bookmark of blogs.msdn.com has no favicons, but with the 404 HTML pages when 
accessing http://blogs.msdn.com/favicon.ico.
The bookmark stored the whole HTML pages as favicon(data:text/html;...) when 
accessing blogs.msdn.com again.

Comment 8

14 years ago
N.B. What I mentioned above are same issues, but in different cases.

Comment 9

14 years ago
http://www.e-scio.net/cqfd/loi.php3

I get the same thing here. There is no <link rel="icon"> on the page however,
and /favicon.ico gives me a 404 on the server.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040723
Firefox/0.9.1+
(Reporter)

Comment 10

14 years ago
I am not experiencing this bug with bitfluxeditor.org, blogs.msdn.com or
www.e-scio.net/cqfd/loi.php3 as I am with select.worldpay.com/wcc/admin .  This
leads me to believe that the bug may be something to do with the HTTPS protocol
used here in combination with the invalid favicon.ico.

(Reporter)

Comment 11

14 years ago
Found another example, under HTTPS:
https://sitepoint.com/bookstore/neworderform.php
Summary: Invalid or missing favicon.ico results in no bookmark icon → Invalid or missing favicon.ico not being saved for HTTPS pages

Comment 12

14 years ago
(In reply to comment #10)
what build are you using?
I can reproduce in the latest Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7) Gecko/20040724 Firefox/0.9.1+.
(Reporter)

Comment 13

14 years ago
Currently using 20040726 branch.

Looks like this bug is similar to bug #120304, although I'm pretty sure the
method of caching favicons has changed since that bug was filed.
Assignee: vladimir → vladimir+bm
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 15

11 years ago
Can anyone reproduce this on current trunk builds?

I'm not sure I quite understand what the bug is, but it seems to work for me on
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007083005 Minefield/3.0a8pre ID:2007083005
none of the above examples works nor is completely clear the scope of the bug, resolving incomplete, if anyone can post further informations and example feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 17

9 years ago
Can no longer reproduce.  Pretty sure this was fixed years ago - it pre-dates Places.
Status: RESOLVED → VERIFIED
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.