GPF Site causes bizarre problems

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Cameron Morland, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Attempting to load the page causes the logo to flash for a moment, then nothing
happens. The currently-viewed page does not re-paint, either when a menu is put
in front or when a window is put in front. The GPF page never loads, 'stop'
button is grayed, and reload button attempts to reload the GPF page.

This may be because the site uses frames and JavaScript.

Using SeaMonkey build 2000012520 on NT.

Comment 1

18 years ago
Reassigning to browser-general for better classification.  Nothing here
indicates that the problem is with the JavaScript engine.
Assignee: mccabe → leger
Component: Javascript Engine → Browser-General
QA Contact: rginda → leger

Comment 2

18 years ago
Created attachment 5078 [details]
[testcase] it's not minimal yet, but it's a boost.

Comment 3

18 years ago
I don't have time to finish off this test case right now, so I'll do it later.
The included test case is small but not minimal. Taking out all the frame stuff
except the NOFRAMES section still causes the bug. this makes me think that
mozilla will always act this way if the frames are bogus. However these frames
aren't bogus, although the javascript might be invalidating them somehow. will
look into more later when i have time. ping me if i don't.

Updated

18 years ago
Assignee: leger → troy
Component: Browser-General → Layout
QA Contact: leger → petersen

Comment 4

18 years ago
Updating QA Contact.

Comment 5

18 years ago
I hit an assert in the content sink
Assignee: troy → rickg
Component: Layout → Parser
QA Contact: petersen → janc
(Assignee)

Comment 6

18 years ago
Troy -- I'm sending this one back to you for two reasons: 1st) the bug cited no 
longer happens for me, and 2nd) I don't get an assert in the content sink. Can 
you produce that?  

(Also, I'm not being lazy here -- I'm leaving for dulles tomorrow and want to 
"clear the decks" as it were).
Assignee: rickg → troy

Comment 7

18 years ago
this bug seems to have gone away.
marking worksforme. I'm using winNT build 2000021316
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

18 years ago
It dissapeared for several daily releases, but is back in the latest milestone. 
I'm using Build ID: 2000022620. I haven't found any other sites that cause this.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

18 years ago
I'm getting the assert in the content sink again. Here it is:

###!!ASSERTION: leaf w/o container: 'mStackPos > 0', file 
e:\...\nsHTMLContentSink.cpp, line 1995
Assignee: troy → rickg
Status: REOPENED → NEW

Comment 10

18 years ago
I don't see the assertion. Page seems to load fine.
(Assignee)

Comment 11

18 years ago
I also don't see the assertion. Petersen, can you reproduce this?
Assignee: rickg → petersen

Comment 12

18 years ago
With the March 11 build, this url fails to rendered in the browser. I get a blank 
page using the Mac and Windows builds.

Comment 13

18 years ago
After breaking down the html in attachment, I was able to located the problem. A 
NOFRAME element is containing a FONT with a nested CENTER (which neither are 
closed). If font is removed, the frameset is loaded. This seems be a residual 
type problem. However, since the  browser is frames capable, it shouldn't be 
activating a noframes element.
Assignee: petersen → rickg

Comment 14

18 years ago
Created attachment 6747 [details]
Modified test case with the font element removed.
(Assignee)

Comment 15

18 years ago
Fixed by latest update.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 17

17 years ago
Verified on
build: 2001-06-27-04-Trunk
platform: Win NT

The above url and test case loads fine.
You need to log in before you can comment on or make changes to this bug.