After "Customize", "about:blank" is correctly shown, but not before "Customize"

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
14 years ago
14 years ago

People

(Reporter: Norbert, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040626 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040626 Firefox/0.8

- open the page "about:blank": the "about:blank" vanishes from the address bar
- right-click the the toolbar "Customize"
- confirm th customize-window to close it:

Now the address bar shows the "about:blank"!

Reproducible: Always
Steps to Reproduce:

Actual Results:  
The adress bar shows another address than before "Customize".

Expected Results:  
"Customize" should not change the address-bar!

But I like what Fireox does after "Customize" more...
So I suggest to show always "about:blank". The fact that "about:blank" is not
shown after entering is irritating for unexperienced users. They could think
it's possible to get an empty page by confirming an empty address bar. IE
correctly always shows "about:blank" if this empty page is "loaded".
about:blank should not be shown at all.

Marking this INVALID, but a bug will be filed on fixing this situation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> about:blank should not be shown at all.
> 
> Marking this INVALID, but a bug will be filed on fixing this situation.

Woah, wait a second, if about:blank should not be shown at all, and the reporter
says that about:blank is being shown, how is this invalid?
(Reporter)

Comment 3

14 years ago
to Mike Connor:

Plese enter the number of this "new" bug here!!!
(Reporter)

Comment 4

14 years ago
because Mike Connor does not react I will reopen this bug.

Furthermore I found out that also DOM Inspector shows "about:blank" if it is
opened while an empty page is in Firefox.


Mike Connor: Would you please tell me why you don't want to have about:blank
shown, like IE does?????
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I'm not cc'ed on the bug, so I didn't respond.  We've already has that
discussion in another bug, as you well know, and I don't want to rehash things
again.

However, this bug is invalid because its saying that the bug is that its not
shown before, when the bug is that its shown after.

The correct bug is bug 256460
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → INVALID
OK, I understand now :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.