editing quoted numbered list (<ol>) causes numbers to reset

RESOLVED DUPLICATE of bug 209090

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 209090
14 years ago
14 years ago

People

(Reporter: Steven Grimm, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Thunderbird build 20040616

If you reply to an HTML message with an <ol> list and insert commentary after
the list entries, the list numbers get reset to 1 after each inserted comment if
you add line breaks.

Reproducible: Always
Steps to Reproduce:
1. Send a message to yourself that includes a numbered list of items.
2. Reply to the message. The original message appears in quoted form with the
blue bar on the left side.
3. Put the cursor at the end of the first item and hit return as if to start
typing a comment about the item.

Actual Results:  
The item number of the second item changes from 2 to 1 as soon as you insert the
line break.

Expected Results:  
It should set the starting index of the newly created <ol> such that the list
isn't renumbered. Otherwise, if you reply to several such items, you end up with
a ridiculous-looking list of quoted items all numbered "1."

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 209090 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.